Chat now with support
Chat with Support

Foglight Experience Monitor 5.8.1 - Release Notes

Resolved Issues and Enhancements

Resolved Issues and Enhancements

The following is a list of issues addressed and enhancements implemented in this release.

Defect ID

Resolved Issue

FXM-959

Upgraded the curl and cur libs to version 7.50.3 to resolve the known vulnerabilities.

FXM-955

Improved FxM's ecrit log file to show Excessive Data Volume related information if this value changes.

FXM-950

The portal sometimes aggregates metrics from both probes, if two probes have been set as the HA mode.

FXM-941

Upgraded OpenSSL to version CVE 2016 2107 to resolve OpenSSL oracle padding vulnerability.

FXM-921

Fixed issue where some siteminder agents were blocked when initializing SMA API.

FXM-920

Fixed issue where netcat command was removed in Foglight Experience Monitor release 5.8.0.

FXM-916

Fixed issue where users were unable to run command ethtool in Foglight Experience Monitor release 5.8.0.

FXM-918

Improved the SiteMinderAgent log to the show debugging information related to siteminder operations.

FXM-856

Improved FxM's log file to show the IP address of the server that uses Diffie-Hellman as key exchange encryption.

Issues resolved in fxm_5-8-0-2017022401_laurel64.pkg hotfix

Defect ID

Resolved Issue

FXM-913

Extra siteminder sites got deleted even if only one site was selected in the portal-probe environment.

FXM-912

Fixed issue where a popup dialog opened but without returned values after clicking Verify Settings in the SiteMinder Configuration page.

FXM-907

Fixed issue where FxM was failed to send scheduled reports to email receivers.

FXM-831

Site with the script tag was not being escaped properly in the resource list.

Issues resolved in fxm_5-8-0-2016092201_laurel64.pkg hotfix

Defect ID

Resolved Issue

FXM-893

Fixed issue where users were unable to run tcpdump directly in the shell.

FXM-890

Fixed vulnerability due to CURL/LIBCURL UP TO 7.50.0 0 - CVE-2016-5419.

FXM-889

FXM-888

Updated msrsdeftool to override MaxObjects and TTL for a single category.

FXM-887

Fixed issue where upgrading from version 5.7.0 to version 5.8.0 failed, due to SiteMinder integration.

FXM-885

Fixed issue where users were unable to add monitoring for IP addresses of type xx.xx.xx.255 (submark /22).

FXM-882

Fixed issue where a slow probe/portal network connection was causing holes in reports, due to configuration loading time.

FXM-879

Fixed issue where the remote syslog did not work after configuring the syslog server IP on Network Settings page.

FXM-875

Fixed issue where the console was capturing traffic, but the auto-discovery functionality was not working correctly.

FXM-861

Permanent cookies contain sensitive session information.

Fix: The cookie itself cannot be eliminated, since it is used to identify the user. In order to address this security concern, customers must shorten the session cookie lifetime, by editing the session.cookie_lifetime setting in the php.ini file. The following is an example where the session.cookie_lifetime is set to expire in 5 minutes:

session.cookie_lifetime = 300

To edit the php.ini file:

  1. Go to the shell through the console program.

  2. Go to the /etc/ecrit directory.

  3. Restart all applications in the console program after making the change.

FXM-859

Fixed issue where the Body parameters were accepted in queries.

Issues resolved in the fxm_5-8-0-2016051201_laurel64.pkg hotfix

 

Defect ID

Resolved Issue

FXM-858

Fixed cross-site scripting issue on the Foglight Experience Monitor web console login page.

 


Known Issues

Known Issues

The following is a list of issues known to exist at the time of this release.

 

Defect ID

Known Issue

FXM-967

After enabling SSL and then disabling SSL access, the FxM web console cannot be logged in, regardless with HTTP or HTTPs protocol.

Workaround: Clear the browser's cookie, and then log into the FxM web console with HTTP protocol.

FXM-802

Retain configured IPs and ports when changing appliance IP.

FXM-665

Column headers in table in PDF report crowded.

FXM-619

Server Auto-Discovery shows no servers with low traffic.

FXM-588

Details link on Server Auto Discovery page brings up wrong server information.

FXM-446

Subnets over 18 Hangul characters in length exceed the Subnet field limit of 64 characters in the Session database.

Workaround: When using Far East characters, limit subnet names to eight characters.

 


Third Party Known Issues

Third Party Known Issues

There are no known third party issues specific to this release of Foglight Experience Monitor.

 


Upgrade and Compatibility

Upgrade and Compatibility

Upgrade the Appliance Software

Download upgrades from the Quest Support Portal (https://support.quest.com/) and install them using the following procedure.

Important: If you are upgrading Foglight Experience Monitor to version 5.8.1, you must also upgrade Foglight Experience Viewer to version 5.7.0.

 

To install an upgrade:

  1. Log into the FxM web console as an administrative user.
  2. Open the Upgrade page by navigating to Help > Upgrade on the top menu.
  3.  In the Upgrade Appliance section of the Upgrade page, click Browse and locate the upgrade .pkg file on your local hard drive.
  4.  Click Upload to upload the package to the appliance.
    The uploading process is complete when the Install button appears.
  5. Click Install to start the update process during which the package is decompressed, decrypted, and then installed into the proper locations on the appliance.

Important: The Log page is displayed until the upgrade installation process requires all system applications to stop. Consequently, the web console will not be available and the system may be offline for a period of 30 minutes to 3 hours. Do not reboot the appliance during the upgrade. When the console program is available during the database upgrade process, you can log in to see the progress of the upgrade. When the web console login page becomes available, the upgrade is complete.

Note: The upgrade file must have a .pkg extension, otherwise you will receive an error message.

 

For detailed upgrade information, see the Foglight Experience Monitor Installation and Administration Guide.

Upgrade Path

The following table shows the version upgrade path that you can take from one version of Foglight Experience Monitor to another. Source Version refers to the current Foglight Experience Monitor that you have installed. Destination Version refers to the highest version of Foglight Experience Monitor to which you can upgrade.

 

Source Version

Destination Version

5.6.2

5.6.3

5.6.3

5.6.5

5.6.5

5.6.6

5.6.6

5.7.0

5.7.0

5.8.0

5.8.0

5.8.1

Compatibility

Foglight Experience Monitor 5.8.1 is compatible with:

  • Foglight Management Server 5.6.5 to 5.9.1
  • Foglight Experience Viewer 5.7.0

 


Related Documents