Chat now with support
Chat with Support

Coexistence Manager for Notes 3.8.1 - Release Notes

Admin CMN servers (running CMN components) support

Windows Server 2016

 

Windows Server 2012

RTM

Windows Server 2012 R2

 

Windows Server 2008 R2, 64 bit

SP1

Directory Connector

Mail Connector and/or Free/Busy Connector (for each)

On every computer hosting any CMG component

Microsoft .NET Framework 2.0, and 4.0 Full Framework. (The CMN Installer provides links to these, as a convenience if they are not already installed.)

Active mail processing requires Lotus Notes client 7.0.3 or 7.0.4, or 9.0.1, or Lotus Notes Basic (not Eclipse) 8.0.0.

Directory Connector

Microsoft PowerShell 3.0 or later, 64-bit (a component of Windows Management Framework 3.0, which comes with Windows 2012 or 2012 R2, or can be downloaded at this Microsoft link).

Microsoft .NET Framework 4.5.2 (in addition to versions 2.0, 3.51, and 4.0 Full Framework as noted above), available at this Microsoft link.

Quest recommends that CMN servers reside in the same domain as Exchange.

Mail Connector

.NET Framework 4.5. is required to support TLS 1.2. It can be downloaded from this Microsoft liink.

Microsoft PowerShell 2.0 or later, 64-bit (a component of Windows Management Framework, which comes with any supported operating system, or can be downloaded at this Microsoft link).

CMN servers can reside anywhere (no domain membership requirement).

Free/Busy Connector

.NET Framework 4.5. is required to support TLS 1.2. It can be downloaded from this Microsoft liink.

CMN F/B Connector servers must reside in the same domain as Exchange.

Microsoft PowerShell 2.0 or later, 64-bit (a component of Windows Management Framework, which comes with any supported operating system, or can be downloaded at this Microsoft link). Also: In some environments this command is necessary to enable the PowerShell layer using remote PowerShell:

Lotus Notes Client 7.0.x to 9.0.1, installed and configured in single-user mode. The Notes user used for the Free/Busy administration server requires a mail file since the user must be able to natively look up a Notes user’s Free/Busy.

CMN’s Autodiscover and EWS require Microsoft IIS 6.0, 7.0, 7.5 or 8.5, and:

CNM port assignments

Upgrade and compatibility

The information in this topic applies only if you are upgrading to the current CMN version from an already-installed earlier CMN version. Installation and upgrade procedures are documented together in the Upgrade and installation instructions topic below.

Upgrading the Directory Connector, Mail Connector, or Free/Busy Connector

There is no need to uninstall a version 3.7.0 or 3.7.1 CMN Directory Connector, Mail Connector, or Free/Busy Connector before installing this new version. The CMN AutoRun application will detect any 3.7.0 or 3.7.1 version installation and install the new software accordingly. If you are upgrading from CMN 3.7.0 or 3.7.1, the automated upgrade process will transfer your existing license key into the new version, so you need not re-install it.

There is no direct upgrade path to CMN 3.8 or higher from any pre-3.7.0 version of CMN. To upgrade from a pre-3.7.0 version to the current CMN release you must first upgrade to a 3.7.0 version (as described in the Quick-Start Guide for that version), and then upgrade from 3.7.0 to the current release.

You can import your existing (pre-3.7.0) DC configuration data into the new Directory Connector. The procedure is documented in the Upgrade and installation instructions topic below.

Related Documents