Chat now with support
Chat with Support

Coexistence Manager for GroupWise 1.7.1 - User Guide

About the Coexistence Manager for GroupWise documentation suite Introduction Coexistence Manager for GroupWise Directory Connector
Directory Connector overview Installation and configuration DC Management Console Connector Creation Wizard Connector Advanced Settings Running and stopping the Directory Connector service
Coexistence Manager for GroupWise Mail Connector Coexistence Manager for GroupWise Free/Busy Connector The Log Viewer Appendix A: Known limitations Appendix B: Troubleshooting Appendix C:Configuring Coexistence Manager for GroupWise logging

Commands to troubleshoot the F/B Connector

Get‑CmgFreeBusyBridge

[-WebServerName] <String>
[-UserEmailAddress] <String>

WebServerName: Name of server where FreeBusyBridge Web Service resides.
UserEmailAddress: Email address for whom to get F/B info from Exchange.

Get‑CmgExchangeFreeBusy

[-UserEmailAddress] <String>
[-StartDate] <DateTime>
[-EndDate] <DateTime>

UserEmailAddress: Email address of an Exchange user.
StartDate: Starting date for the F/B search.
EndDate: Ending date for the F/B search.

Get‑CmgGroupWiseFreeBusy

[-UserEmailAddresses] <String[]>
[-StartDate] <DateTime>
[-EndDate] <DateTime>

UserEmailAddresses: List of email addresses of GroupWise users.
StartDate: Starting date for the F/B search.
EndDate: Ending date for the F/B search.

Get‑CmgExchangeWebServicesUrl

[-EmailAddress] <String>
[-Credentials <PSCredential>]

EmailAddress: Email address of an Exchange user.
Credentials: Credentials to access the Exchange Service. Use Get-Credential to get the credentials.

 

The Log Viewer

The Log Viewer utility simplifies the viewing and interpretation of program log files, which document errors and warnings in Quest programs. The same Log Viewer is used for Quest’s MFG, CMG, MNE and CMN products.

IMPORTANT: The full benefit of Quest's Log Viewer requires the application to transmit log event codes from the computer hosting the Log Viewer to a remote Quest database of Solutions (useful information about the events associated with the log codes). The Quest Solutions database then sends a corresponding Solution back to the Log Viewer for display to the user.

This feature is enabled by default, but can be disabled by deselecting the Enable Internet Access option on the View menu. For more information, see the IMPORTANT disclosures in the View menu topic below, in the field notes for the Enable Internet Access option.

These Log Viewer topics document Log Viewer menus and toolbar and How to ... (accomplish various tasks).

Log Viewer menus and toolbar

Most Log Viewer features are accessible by the program’s menus and/or the program tool bar, which share a horizontal band across the top of the screen:

Several features are also available directly from the keyboard, and those keyboard shortcuts are displayed in the menus and noted here.

Open Log File... (or Ctrl+O): Opens a standard Windows Open dialog box, from which you can specify the file you want to open into the Log Viewer. The Log Viewer can open and display MFNE/MFG (compressed) files, and tsv, csv and plain text files.
Save Copy Of Log File As... (appears only when a file is open): Opens a standard Windows Save As dialog box, from which you can specify the filename and location where you want the open file to be saved. The Log Viewer lets you edit the contents of an open file, but will not replace the original on disk with the edited version (you cannot save it under the same name in the same location).
Recent Files: Shows a list of recently opened files, from which you can select a file to re-open (to quickly re-open a file you have recently viewed and closed).
Exit: Closes the Log Viewer window.
Copy (or Ctrl+C): Copies the selected string to the Windows clipboard.
Find... (or Ctrl+F): Opens a Find dialog box that lets you specify a text string to search for within the open file.
The Find feature highlights the entire line that contains the target string:
Show Line Numbers (or Ctrl+L): Toggles the display of line numbers (within the open file) on and off.
Show Complete Log Entry (or F5): Opens a Log Detail window that shows the entire error string for the selected error—useful when the error text overruns the Log Viewer’s maximum line length (maximum 259 characters), or if the line extends beyond the right edge of the viewer window without wrapping.
Enable Internet Access: Toggles the Internet connection on and off. Note these important disclosures:
IMPORTANT: The full benefit of Quest's Log Viewer requires the application to transmit log event codes from the computer hosting the Log Viewer to a remote Quest database of Solutions (useful information about the events associated with the log codes). The Quest Solutions database then sends a corresponding Solution back to the Log Viewer for display to the user.

This feature is enabled by default, but can be disabled by deselecting this Enable Internet Access option (on the View menu). Note:

Quest's transmission of Solutions corresponding to received event codes is fully automated (no human intervention or observation). Quest tallies the frequencies of event codes received and Solutions sent in reply, but does not associate those tallies with IP addresses or any other personally identifying information, and no other information is logged.
Quest servers treat each received event code as a query. Quest uses an event code only to determine which Solution to send back to the source of the query, and uses an IP address only to transmit the Solution to the source of the query. Quest servers log querying IP addresses as a matter of course, but Quest does not use them for any other purpose and does not disclose them to any other entity.
Goto Line Number: Prompts for a line number in the file to display.
Online Help... (or F1): Opens Quest’s online Help file for the Log Viewer, which documents its features.
About...: Opens a window of information about the Log Viewer—identifying the current release, and asserting Quest’s intellectual property rights to the software.

How to ...

This section describes how to complete various tasks in the Log Viewer.

Click the Open Log File button to view a list of log files that can be opened. In the File section of the screen, select a log file and click OK to open the log in the Quest Log File Viewer.
NOTE: The Open Log File button in the Management Console’s Health screen is enabled only when the UdpAppender is defined in the log42net.config file of at least one module. During a new installation, the Log Viewer installer installs a file with the required Udp­Appender. During an upgrade, however, the installer does not overwrite the log42net.config file, so the UdpAppender is not present, and this makes the Open Log File button invisible. To correct this, see To Add the UdpAppender to an Existing Log File at the end of the Configuring Coexistence Manager for GroupWise Logging Appendix.
Edit menu | Find... (or Ctrl+F): Opens a Find dialog box that lets you specify a text string to search for within the open file. The Find feature highlights the entire line that contains the target string.
File menu | Recent Files: Shows a list of recently opened files, from which you can select a file to re-open (to quickly re-open a file you have recently viewed and closed).
File menu | Save Copy Of Log File As... (appears only when a file is open): Opens a standard Windows Save As dialog box, from which you can specify the filename and location where you want the open file to be saved. (This feature does not permit any revisions to the open file. It simply lets you save the file in its original form to a new filename and/or a new location.)
View menu | Show Line Numbers (or Ctrl+L): Toggles the display of line numbers (within the open file) on and off.
View menu | Show Complete Log Entry (or F5): Opens a Log Detail window that shows the entire error string for the selected error—useful when the error text overruns the Log Viewer’s maximum line length (maximum 259 characters), or if the line extends beyond the right edge of the viewer window without wrapping.
View menu | Enable Internet Access: Toggles the Internet connection on and off.
Edit menu | Copy (or Ctrl+C): Copies the selected string to the Windows clipboard.
File menu | Exit: Closes the Log Viewer window, or click the Log Viewer Close box ([X]) to dismiss the window and return to the previous display.
Related Documents