When installing QSA on windows the above error can occur due to several reasons indicating that the daemon was not created
Possible cause is the instance not seen in registry due to re-imaging the server. This will manifests as
- unable to create the QSA config file
-unable to create or install the QSA
-unable to start the QSA
-wrong parameters in the config file
Correct the config file entry for QSA install directory (install_dir) to resolve this issue:
SELECT name, value FROM quest.quest_exec_parameter WHERE NAME LIKE 'INSTALL%';
Results will look like this
INSTALL_DIR : C:\Program Files\Quest Software\Quest Server Agent\<<SID>>
INSTALL_ACCT: QUEST
Note: the SID name should be part of the directory at the end otherwise the "-c errorr 3 will be received).
To avoid this error, the entire directory structure should be entered in the config file:
Here is a sample to create the qexecd.conf file
ORACLE_HOME="<value>"
ORACLE_SID="<value>"
ORACLE_USER="<value>"
ORACLE_PASS=
QSA_INSTALL_DIR=" C:\Program Files\Quest Software\Quest Server Agent\<<SID>>"
QSA_USER="<value>"
NLS_LANG="AMERICAN_AMERICA.xxxx"
QSA_LICS="XxX"