A truncate partition ddl message was performed on source and the corresponding partition does not exist on the target.
errors in event_log and or opo logs show the following
Info 2012-10-11 01:22:46.132698 12720 1 Poster exited with code=1, pid = 3224 (posting from QUEUE, queue QUEUE, to HOST)
Error 2012-10-11 01:22:46.116479 3224 4 s:4 Poster: Poster exit on 9i ddl error due to ORA-02149: Specified partition does not exist. on alter table OWNER.TABLENAME truncate part... (posting from QUEUE, queue QUEUE, to HOST) [module opo]
Notice 2012-10-11 01:22:46.115929 3224 4 s:4 Poster: ORA-02149: Specified partition does not exist. (posting from HOST, queue QUEUE, to HOST) [module osp]
Info 2012-10-11 01:22:40.912643 3224 1 Poster launched, pid = 3224 (posting from HOST, queue QUEUE, to HOST)
Notice 2012-10-11 01:22:40.893096 29373 1 User command: oracle start post (from HOST)
Error 2012-10-11 01:16:23.007317 13135 5 s:2 Table "OWNER"."TABLENAME" out of sync for queue QUEUENAME source rowid AAaaJoAAhAAKoE5ABE: Row Not Found (po
The sql is not valid on the target bacause the partition does not exist.
Just starting post will skip this invalid ddl, the issue here is that the ddl uses a "
alter table OWNER.TABLENAME truncate partition PARTNAME UPDATE GLOBAL INDEXES parallel 8"
The post needs to be restarted 8 times for it to skipp all 8 ddl statements or whatever the parallel value was.