Agents stopped and cannot be activated. On the "Agent Status" dashboard the agent collection seems to be stopped and the "Status" column is showing a gray cross.
When trying to activate the agent, the message "Agent cannot be activated" appears.
Cause 1
FglAM (Foglight Agent Manager) was not running.
Cause 2
Agent package has been undeployed accidentally.
Resolution 1
Go to the "Agent Manager" dashboard and restart the Foglight Agent Manager (FglAM). If that does not work, log in the FglAM host and start it from there. For a Windows machine go to the Services and start up the FglAM service.
For Linux machine go to $FGLAM_HOME/bin and start it using the command: ./fglam -d
Resolution 2:
Re-deploy the agent packages on the FglAM. Go to the Agent Status dashboard on click on "Deploy Agent Package". Then select the FglAM where the agent used to run on and in the next step, select the agent package which you want to re-deploy.
© 2024 Quest Software Inc. ALL RIGHTS RESERVED. Feedback Terms of Use Privacy Cookie Preference Center