After adding IIS DotNet agents, some of the application pool agents for the same monitored server are showing as broken.
CAUSE 1
The application pool is stopped or there is no worker process is running for that application pool.
CAUSE 2
Foglight Agent Host for Microsoft .NET service is down.
WORKAROUND 1
Ensure that the application pool is started and access the site that uses the pool to trigger the worker process. Refresh the Monitoring Agents dashboard page to update the agent status.
WORKAROUND 2
Restart the "Foglight Agent Host for Microsoft .NET" service from Windows Services. From Task Manager, ensure that the agenthost.exe is running.