Issue
Migrations fail to initialize and report the below error in the migration log:
Warning connecting to default folder: Error in IMAPISession::OpenMsgStore: MAPI_E_FAILONEPROVIDER
Error: Microsoft Exchange is not available. Either there are network problems, or the Exchange server is down for maintenance.
[Error] Unable to logon to Hosted Exchange Mailbox: user@domain.com
Cause
The migration system utilizes MAPI to connect to target mailboxes in Exchange On-Prem and Office 365. This error can be caused by MAPI not being enabled on the target mailbox, the migration Outlook account not being granted access to the target mailbox or MAPI connection limits in the target Exchange or Office 365 system.
Exchange on premise and Office 365 have Throttling Policies that restrict the number of connections that a single Outlook account can make as well as restricting data processing through Burst Allowances and Maximum Usage. These can be reviewed in online Microsoft tech notes.
Solution
1. Verify that MAPI is enabled for the account mailbox to be migrated. This can be checked in the Exchange or Office 365 Admin portal for the mailbox properties under mailbox features.
2. Verify that the Full Access delegation has been granted for the migration Outlook account configured on the migration worker. This can be viewed in the Exchange or Office 365 Admin portal for the mailbox security. Notes Migrator does provide a button to update this "Set Full Access".
The Outlook migration account can be a single mailbox account or more typically is a mail enabled security group containing multiple Outlook accounts in Exchange or Office 365 eg. FullAccessAdmin@domain.com that can be configured on the Notes Migrator Settings document. For Exchange migrations this is the User Provisioning | Account Performing Migrations and for Office 365 migrations this is the Office 365 | Office 365 Security Group.
If there are no workers configured and migrations are using the Migration Control Center server then the Required Settings | Additional | Autodiscover UPN Account will be used for the Outlook migration account.
3. Review the number of migration workers that have the same Outlook migration account in use. To limit the impact of Throttling Policies, Binary Tree recommend one Outlook account per five migration workers for Exchange on premise migrations and one Outlook account per two migration workers for Office 365 migrations (preferably an Outlook account per worker for Office 365 if possible).
4. Verify that the target Exchange or Office 365 system is available through the network connections from the migration worker and for Exchange on premise that Exchange is running for the mailbox server that the Outlook migration account and target mailbox are configured to use
5. Verify that there are no certificate errors being reported for Exchange or Office 365 connections in Outlook.
6. Verify DNS is configured for autodiscover for all SMTP domains that migration accounts will be using or configure a local workstation Hosts file entry for the IP of the autodiscover endpoint.
7. If all above steps fail, delete all MAPI profiles, run a repair of Outlook, run fixmapi, open Outlook and configure a new MAPI profile.
Note1: the migration Outlook account can be set and verified on a migration worker using the Connectivity Tester application. The migration Outlook account does require a full mailbox with MAPI enabled.
Note2: this can also be caused in cases where Exchange or Office 365 have not fully initialized the target mailbox, typically allowing for 30 minutes and then re-submitting the migration does allow for the connection to the target mailbox to be completed.
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