Received the error: "Could not convert variant of type (Null) into type (OleStr)" when performing one of the following actions:
- Connection
- Creating profile
- Renaming profile
CAUSE 1:
Application is unable to locate the connection profile file
CAUSE 2:
Windows client does not have the 'C:\Documents and Settings\All Users\Application Data\Shared\Profiles' directory
CAUSE 3:
The connection profile file(s) is/are invalid or corrupt.
CAUSE 4:
Product defect
WORKAROUND 1:
Modify the connection profile directory appropriately through the Connection Manager.
1. Launch Performance Analysis
2. At the Connection Manager, click on the Tools | Options, then set a valid connection profile directory to the path 'C:\Documents and Settings\All Users\Application Data\Shared\Profiles' directory.
Please note:
Prior to setting the connection profile directory , open Windows Explorer and back up your Profiles directory
WORKAROUND 2:
1. Shutdown Quest Central / Performance Analysis
2. Back up the contents of the profiles directory (C:\Documents and Settings\All Users\Application Data\Quest Software\Shared\Profiles)
3. Delete all files and folders from the Profiles directory
4. Restart Quest Central / Performance Analysis .
Please note:
It will be necessary to re-enter logon information
WORKAROUND 3:
1. Search through all the profiles folders looking for any folder that has a profile.xml that is 0 bytes in size.
2. Delete any of these corrupted folders that contain the 0 byte profile.xml.
3. Once you have removed all corrupted directories you need to recreate any profiles that you had to delete.
Additional information:
In versions prior to Performance Analysis 6.1.113, the connection profile is predefined to store in the 'C:\Documents and Settings\All Users\Application Data\Shared\Profiles'
This error may occur in Quest Central.
WORKAROUND 4:
Use this workaround if a profile with the name "New" is created instead of the selected/specified name.
1. Close Performance Analysis client.
2. Go to the connection profile directory 'C:\Documents and Settings\All Users\Application Data\Quest Software\Shared\Profiles\New\',
3. Open profile.xml file then find and replace "New" with the "<Instance Name>" and then save the file.
4. Rename the directory from 'C:\Documents and Settings\All Users\Application Data\Quest Software\Shared\Profiles\New\'
to
'C:\Documents and Settings\All Users\Application Data\Quest Software\Shared\Profiles\<Instance Name>\ '
5. Open Performance Analysis client. The profile name will then be displayed correctly.
STATUS:
Waiting for fix in a future release of Performance Analysis Oracle and Performance Analysis SQL Server.
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