Migration is unable to proceed with the error "Mail migration failed because the target user does not have a license for a mailbox". Target Mailbox is a shared Mailbox where no license is required
Possible cause 1
Target mailbox is incorrectly/updated with the response of the mailbox type on Microsoft end.
Possible cause 2
Target user/mailbox is disabled.
Workaround for Possible cause 1
1) Convert the mailbox to a Standard Mailbox and then convert it back to a Shared Mailbox to force the Microsoft backend to update the correct mailbox/user type so it can be properly detected by ODM.
2) Perform account refresh steps as referenced to this KB
Solution for Possible cause 2
Enabled the target account and performed the account refresh steps as referenced to this KB