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DirSync: Unable to configure an internal field for attribute EnrollmentProfileName. There are no available internal fields.
Description
The read workflow fails with the below error:
Unable to configure an internal field for attribute EnrollmentProfileName. There are no available internal fields.
CDS.Library.ApiHttpException: Unable to configure an internal field for attribute EnrollmentProfileName. There are no available internal fields. at CDS.Library.WebAPI.ApiClient2.CheckResponse(IRestResponse response, Method method, String resource) at CDS.Library.WebAPI.ApiClient2.ExecuteAndCheck(Method method, String resource, Object content, Stream outputStream) at CDS.Library.WebAPI.ApiClient2.Execute[T](Method method, String resource, Object content) at CDS.Model.EndpointWebServices2.EnsureInternalFields(Nullable`1 sourceEndpointId) at CDS.Model.PushJob.Run(IWebServiceFactory webServiceFactory, CancellationToken cancellationToken) at CDS.Model.Job.Execute(IWebServiceFactory webServiceFactory, CancellationToken cancellationToken) Error details from server: Message = An error has occurred. ExceptionMessage = Unable to configure an internal field for attribute EnrollmentProfileName. There are no available internal fields. ExceptionType = System.Exception StackTrace = at CDS.Model.EndpointSql.EnsureSpecificInternalFields(Int32 endpointId, IEnumerable`1 attributes) at BTCloud.PrivateApi.Areas.PrivateApi.CDS.Controllers.EndpointController.EnsureInternalFields(Nullable`1 endpointId)
Cause
The EnrollmentProfileName attribute is part of the mapping template.
Resolution
Workaround: Remove the EnrollmentProfileName attribute from the template being used in the affected workflow and retry the read workflow:
Additional Information
If the issue persists or the attribute cannot be removed, please reach out to support for further assistance.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
On Demand Migration
Current
Topic(s):
Troubleshooting
Article History:
Created on: 4/23/2024 Last Update on: 11/5/2025
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Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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