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ODM Mailbox Migration Task Failed Error: "No valid accounts specified for mail migration"
Description
When migrating user mailboxes with On Demand Migration (ODM) you may encounter the following error, resulting in a Failed migration task:
No valid accounts specified for mail migration
Cause
This error typically occurs because the user in the source Office 365 tenant has not been licensed. All users that are going to be migrated with ODM will need a license for each type of data that is going to be migrated (Exchange Online, Teams, SharePoint, OneDrive, etc.).
Resolution
Ensure the user is active and has a license applied in the source Office 365 tenant.
Note: If the user was missing a license in Office 365 and one was just applied, you may need to wait for a mailbox to be created or propagation delay.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
On Demand Migration
Current
Topic(s):
Troubleshooting
Article History:
Created on: 8/14/2020 Last Update on: 11/26/2025
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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