DLL conflictswhen VDDK installed on vCenter Server.
Usually VDDK libraries are installed on a backup proxy (physical or virtual machine) but when they are installed on vCenter Server, libldap_r.dll and liblber.dll could be different versions, causing “One or more required subsystems failed to initialize” errors.
Ref: https://www.vmware.com/support/developer/vddk/vddk-600-releasenotes.html
Its a good to have dedicated backup proxy, physical or virtual, instead of trying to install this on the vCenter. We currently do not support installation of the VMware Plugin on the vCenter.
Aside from the library conflict errors, there is the consideration of putting additional load on the vCenter server which is a core infrastructure machine, which I generally advise against.
Install the VMware Plugin on a backup proxy, this can be a physical or virtual machine, as long as the virtual machines use virtual disks that reside on VMFS datastores created on local storage, iSCSI, or FC SAN.
If physical and with FC SAN storage, it must be a physical machine and have direct access and Full R/W permission to the SAN LUNs which contain the VMFS volumes (datastores) with virtual disks or the virtual compatibility RDMs.
To ensure this, add the NetVault Backup Client to the same fabric zones to which the ESX Server belongs.
Additionally, set the same host mode (connection type) on the NetVault Backup Client and the ESX Server. For example, if you have an IBM array with the host mode set to LNXCL, use the same setting for the NetVault Backup Client.