A backup of a mounted drive that resides on a Dell EqualLogic PS6100XS box fails with a VSS_E_PROVIDER_VETO error message.
The errors in the Binary log were:
1] Error creating volume snapshot(s): VSS_E_PROVIDER_VETO
2] Failed to create VSS snapshot
3] An error occurred when processing the final tree and backup options
4] Failed to prepare the selection tree and backup options
5] Job Status: Backup Failed
From the NetVault Client Filesystem Plugin (nvfs725):
2 FSOFM ??? 5688 22 0 121612495525 OFM - Is NOT installed: Error='2'
2 NVFSWIN ??? 5688 669 0 121612495525 VSS wanted for job. Try init...
0 LICENSE ??? 5688 255 0 121612745123 No site/cluster license for this plugin
2 VSS ??? 5688 673 0 121612745123 VSS - Not licensed (cannot get caps)
2 VSS ??? 5688 14 0 121612745123 VSS found volume 'F:\'
2 VSS ??? 5688 3 0 121612932321 Asynchronous GatherWriterMetadata starting...
2 VSS ??? 5688 4 0 121615303507 Asynchronous GatherWriterMetadata finished.
2 VSS ??? 5688 5 0 121615319107 Number of writers that responded: 10
2 VSS ??? 5688 6 0 121615319107 Add volume 'F:\' to the volume list
2 VSS ??? 5688 1 0 121617549893 Error in c:\BUILD\Windows\LIMA_2013MAY03_901023\source\hb2\filesystem\windows\fsvss.cpp(388). Call gptBackupComponents->AddToSnapshotSet( oVolume->pwstrVolume, GUID_NULL, &(atSnapshotsArray[oVolume->lVolumeId])) returned 0x80042306
2 VSS ??? 5688 13 0 121617549893 **** VSS Return code: VSS_E_PROVIDER_VETO****
2 VSS ??? 5688 677 0 121617549893 Release class and CoUnit...
0 HBBACKUP ??? 5688 192 0 121617581093 Sub-level selection-tree-complete check failed
0 HBBACKUP ??? 5688 165 0 121617581093 Failed to prepare selection tree/backup options
Then went through the following KBA for a "VSS_E_PROVIDER_VETO" error message and goes into more detail about the diagnostics and solutions:
https://support.quest.com/SolutionDetail.aspx?id=SOL79141
Unfortunately this didn’t resolve the issue.
Additionally the returned error number (0x80042306) points to a 3rd Party VSS issue (in this case it is the Smart Copy on the Dell Equallogic PS6100XS) i.e. when a VSS provider blocks the creation of the VSS snapshot.
A restart of the Volume Shadow Service should fix this issue. If this doesn't resolve the issue, please try following steps before retrying the
backup:
1. The writer may be in failed state, so to verify the writer status run the following command through the command prompt on the Server:
vssadmin list writers
Ensure that no writers in the list show any errors. In case a Writer is in an error state, reboot the server to make the writer stable again.
2. To verify the snapshot providers, run the following command through the command prompt on the Exchange Server:
vssadmin list providers
Check the output and see how many providers are installed.
There is a possibility that too may VSS providers are performing the same action at the same time.
You can also see the list of providers also under the registry:
HKey_Local_Machine\system\CurrentControlSet\Services\VSS\Providers
In this case there was the Microsoft and Dell’s Smart Copy VSS Providers listed and we resolved the issue by disabling the Dell’s Smart Copy VSS Provider.
NOTE: Please backup the full registry before making any changes and if you are not confident to make any changes, then please raise a case with Microsoft as we cannot be made accountable for any adverse effects on your system from any changes made. Thanks you.