NDMP sub job duplication fail after 10 minutes
NetVault 10.0.5.27
NDMP Client plugin 10.0.5.12
NDMP sub jobs do not inherit advanced option media time out value from the master job but uses default value causing sub job duplications to fail after 10 minutes if media request is not met.
Master NDMP job has media timeout set to 0 which means never timeout but when the phase 2 job starts we see “Media timeout set to 10 minutes” as seen below in binary log extract. If the media request if not fulfilled within 10 minutes the backup fails.
Information 2015/05/06 07:59:12 18132 Data Plugin grader.org.aalto.fi Media timeout set to 10 minutes 0 seconds
It should also be noted that other options do not get inherited such as if you select do NOT deduplicte the backup the default is again selected and deduplicte backup is selected.
BUG 29034
NDMP sub jobs do not inherit advanced option media time out value from the master job
Until bug 29034 is resolved we have two options
1/ backup 1 volume in the backup so sub jobs are not required and duplication will work as expected
2/ enable job retries in the secondary copy, schedule set, with number of retries set to 10 and Retry After set to 1 hour. This will give the backup 10 tries to obtain a tape over 10 hours, which should be enough to fulfil the required media request.