Issue
When performing an initial forest population or forest refresh, the process seems to execute, but results in no mailbox being displayed in the Exchange Pro Administrative Portal. A review of the event log shows the following: “BinaryTree.E2E.DomainServices.DataModels.CMTEUP_Forest.get_DefaultTimeZoneID()”
Further, while the Exchange Pro Persons table has been populated, tables relating to servers are empty.
Cause
Exchange Pro gathers time zone information from the environment’s Exchange servers to manage the various levels of scheduling within Exchange Pro. If a server returns an unexpected time zone value, the server objects will not process correctly.
Solution
From a PowerShell prompt on an Exchange server, execute the following command:
[TimeZoneInfo]::Local
Note the values returned for “Standard Name” & “Display Name”
In SQL Server Management Console, edit the top 200 rows of the dbo.BT_TimeZone table. Find the row corresponding to your local time zone, and update “Standard Name” & “Display Name” values, per the PowerShell query. Do not modify the value for “Serialized String”
i.e.
Original:
BT_TimeZone_PK | StandardName | DisplayName | SerializedString |
40 | Romance Standard Time | (UTC+01:00) Brussels, Copenhagen, Madrid, Paris | Romance Standard Time;60;(UTC+01:00) Brussels, Copenhagen, Madrid, Paris;Romance Standard Time;Romance Daylight Time;[01:01:0001;12:31:9999;60;[0;02:00:00;3;5;0;];[0;03:00:00;10;5;0;];]; |
Corrected: | |||
BT_TimeZone_PK | StandardName | DisplayName | SerializedString |
40 | Paris, Madrid | (GMT+01:00) Bruxelles, Copenhague, Madrid, Paris | Romance Standard Time;60;(UTC+01:00) Brussels, Copenhagen, Madrid, Paris;Romance Standard Time;Romance Daylight Time;[01:01:0001;12:31:9999;60;[0;02:00:00;3;5;0;];[0;03:00:00;10;5;0;];]; |
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