Issue
After a successful cross forest mailbox migration by E2E, users may notice their Outlook Profile's SMTP address displayed at the root level of the default folder structure still has the Source SMTP address prior to the mailbox migration displayed.
Cause
This is by design for Outlook. The email address stamped in the root folder is determined at profile creation time and should reflect the primary SMTP address stamped on the user.
Solution
Although the address is strictly cosmetic some customers require it be changed if the users primary SMTP address changes. The only supported method at this time to change this is to delete and recreate the profile for the user.