Issue
When creating your initial Forest with ExPro, you submit the forest creation and the below error is shown:
Entity save conflict encountered.
Entity state: Deleted IsDeleted: True Conflict Properties: Not Available
Cause
ExPro licenses were incorrectly created as "O365 mailboxes" and therefore are requiring the target to be an O365 environment. The target that is trying to be added is On-Prem.
Resolution
First, the existing forest needs to be cleared out of the database by following the below steps:
1. Open SQL Management Studio
2. Right-click on the ExPro database > select New Query
3. Type the following within the New Query Editor window: Select * from CMTEUP_Forest ...This will show you the existing forest. Note the ForestID.
4. To delete the forest, run the following: delete from CMTEUP_Forest where Forestid='ForestIDNumberFromPreviousStep'.
5. This will delete the forest from the DB.
6. Now close out of DirSync and restart the BinaryTree Exchange Pro MCP service.
Next, go to the ExPro licensing portal, change the client's license type to the correct "Inter-org" or "Intra-org" mailbox type, and re-import the new license file to ExPro. You should now be able to run through the wizard successfully.