restore fails if database being restored is default database for user attempting restore - ERROR: RESTORE cannot process database databasename because it is in use by this session. It is recommended that the master database be used when performing this operation.
Steps to Reproduce: create database TEST, create user APRIL, for user APRIL, make TEST the default DB. backup the DB, then attempt a restore, should fail with error above
Actual Results: LiteSpeed does not internally change the connection context away from the default database (which is the restore target), causing restore to fail
The database being restored is default database for user attempting restore. This generates two sessions.
WORKAROUND:
Users default database cannot be the one being restored. It is recommended that the master database be used when performing this operation.
STATUS:
The fix for this issue (CR66083) is included in version 5.2.0.x. The latest version of LiteSpeed can be downloaded at:http://support.quest.com/support_download/Downloads.asp