Chat now with support
지원 담당자와 채팅

NetVault Backup Plug-in for MySQL 11.4 - User Guide

Introducing NetVault Backup Plug-in for MySQL Installing and removing the plug-in Configuring the plug-in Backing up data Restoring data Working with native MySQL replication Using the plug-in in a Failover Cluster environment Troubleshooting

Target audience

While advanced MySQL database administrator (DBA) skills are not required to create and run routine backup operations, they are required for defining an efficient backup-and-recovery strategy and performing advanced recovery scenarios.

Recommended additional reading

Quest recommends that you have the following documentation available for reference while setting up and using this plug-in.

MySQL <X> Reference Guide (where <X> refers to the version of MySQL installed on the MySQL Server):
Quest NetVault Backup Installation Guide: This guide provides details on installing the NetVault Backup Server and Client software.
Quest NetVault Backup Administrator’s Guide: This guide explains how to use NetVault Backup and describes the functionality common to all plug-ins.
Quest NetVault Backup CLI Reference Guide: This guide provides a description of the command-line utilities.

 

Installing and removing the plug-in

Installation prerequisites

Before installing Plug‑in for MySQL, verify that the following software is installed and properly configured on the machine that is to serve as the MySQL Server:

NetVault Backup Server and Client software: At a minimum, the NetVault Backup Client must be installed on the machine configured as the MySQL Server.
Enable the Binary Log on the MySQL Server (MySQL Standard/Community option only): This setting allows for support of Point-in-Time (PIT) backups and restores of the MySQL Server. For more information, see Enabling the Binary Log on the MySQL Server (Standard/Community option only).
Proper version of the MySQL Database Client package: The plug-in interacts with components installed with the MySQL Client package and lets you access more functionality with the plug-in. The version of the components installed with this package must be compatible with the installed version of MySQL. Primarily, these two MySQL components should be installed and their version verified:
mysqldump: This utility lets you perform backups and restores of multiple types of MySQL storage engines. Verify that the version of this component is compatible with the current version of MySQL, and that it is not the version provided with an earlier version of Plug‑in for MySQL.
mysqlbinlog: This utility lets you use PIT backups and restores. Ensure that the proper version of this component is available for use with the installed version of MySQL.
MySQL Enterprise Backup: If you want to use the MySQL Enterprise Backup option (MEB-based method) in a standalone (noncluster) environment, your environment must meet the following requirements:
IMPORTANT: If you use Windows Server 2008 R2 or Windows Server 2016, use Windows Computer Management to add Local account and member of Administrators group to the machine's local Administrators group.

If you use RHEL 6.x, verify that the libraries are up-to-date before continuing.
관련 문서