Chat now with support
지원 담당자와 채팅

NetVault Backup Plug-in for DB2 11.4.5 - Release Notes

Resolved issues

On Windows® platforms, corrected an issue in which NetVault Backup resources, such as shared memory, were not released after running a backup or restore job. The behavior was the same whether the job failed or succeeded or was canceled for any reason.

DNPDB2-91 (16775, DBG‑189)

Corrected an issue that occurred during the browse or backup process. The plug-in uses a DB2® API function to release memory that was previously allocated by DB2 on behalf of the plug-in with an incorrect memory pointer. This API function tried to release memory in the wrong location, which caused DB2 diagnostics to log “Possible memory corruption detected” and “Memory validation failure” errors in the db2diag.log file.

DNPDB2-214 (28264)

Improved handling of how the plug-in shared library is invoked during a Plug‑in for DB2 backup or restore job for a NetVault Backup Linux® Pure64 installation. This improvement corrects an issue in which DB2 diagnostics logged severe errors about not being able to access or load nonexistent plug-in shared library libdb2hook64.so.

DNPDB2-215 (28887)

Added support for a hidden configuration parameter that lets you indicate whether the plug-in should update the database heap (dbheap) setting during the roll-forward phase of a restore job.

To use this parameter, add the following stanza to the “nvdb2.cfg file” on the NetVault Backup Client.

If the parameter is set to FALSE, the database heap is not updated during the roll-forward phase. If the parameter is omitted or is set to TRUE, the database heap is update during the roll-forward phase.

DNPDB2-227 (31575)

Known issues

The plug-in does not support the following features:

 

Restoring Incremental and Delta Backups fails if more than one session was used during the creation of the backups. To avoid this issue, verify that you set the Number of Sessions field in the Default Backup Options - Plug‑in for DB2 to 1 for Incremental and Delta Backup jobs. If the field is set to a different number, the plug-in limits the number to 1, and displays the following message (the backup job completes with warnings):

Backup Option 'Number of Sessions' = '<x>' changed to '1' for 'INCREMENTAL' or 'DELTA' backup

where <x> matches the configured number.

DNPDB2-199 (23170)

The plug-in uses a DB2 API function to connect to a DB2 Instance. Because of a bug in this function for DB2 9.7, 10.1, and 10.5 on HP-UX Itanium, the plug-in fails to connect. Therefore, the plug-in does not currently support DB2 9.7, 10.1, and 10.5 on HP-UX Itanium.

DNPDB2-207 (23440)

System requirements

Upgrade and compatibility

Plug‑in for DB2 11.4.5 requires NetVault Backup 10.0 or later. For complete supported-platform information, see the Quest NetVault Backup Compatibility Guide.

관련 문서