지금 지원 담당자와 채팅
지원 담당자와 채팅

Metalogix Content Matrix 9.4 - eRoom Edition User Guide

Introduction Entering the License Key Selecting the SQL Database You Want to Connect to Content Matrix Console End User Interface Connecting to eRoom Connecting to SharePoint Preparing for Your Migration Initiating a Migration Configuring Copying Options Saving or Running a Migration Action Mapping Links and Running Link Correction Incremental Migration Log Files Using PowerShell with Content Matrix
Adding PowerShell Snap-Ins for the Application Framework Using Powershell for Nested Content Reports and Pre-Migration Check Content Matrix PowerShell Commandlet List
Metalogix.System.Commands Metalogix.SharePoint.Commands Metalogix.Jobs.Reporting.Commands Metalogix.ERoom.Commands
Modifying Content Matrix Configuration and Settings Frequently Asked Questions About Us

Items View Tab

The Items View tab displays any items/documents that exist directly under the selected node (that is, the content of any subfolders under the selected node-will not be displayed), along with column metadata.

CONTEN~1_img15

There are four main options that are available through this tab. These options are:

·Search – To perform a full or partial text search, enter the string in the search box then either and either press <Enter>, or click the magnifying glass icon to run the search.

NOTE:  The search will be run on the name column (the FileLeafRef) by default, but you can select a different column to search from the drop-down to the right of the search box.

CONTEN~1_img16

·Refresh - This button will refresh all of the items in the Items View tab.

·Show/Hide Version History - This button option is only available when the selected document library/list has versioning configured. When this button is selected the Items View tab will be divided into two sections, a top section displaying all of the items/documents and a bottom section displaying all of the versions for the selected item/document.

Items View

When an item/document is selected in the top window, all of that item/document's version’s will be listed in the bottom half of the window. You can then look at the metadata for each item/document version that exists. This option can be combined with the Show/Hide Properties button.

If the Show Version History button has already been selected, this will change to be a Hide Version History button instead. You can use this option to stop looking at item/document version histories.

·Show/Hide Properties - The Show Properties button allows you to see a list-style view of the available fields (columns) and their values, for a selected item/document. Any value listed in dark text can be edited and within the window.

Items View Properties

The fields in the Properties window can also be ordered by category, or alphabetically. By default, the fields are ordered by category, and are listed alphabetically within each category. If listed alphabetically, then all property fields (columns) will be listed in alphabetical order, with no breakdown by category. There are two buttons at the top of the Properties window that can be used to determine what ordering type is used. This option can be combined with the Show/Hide Version History button.

If the Show Properties button has already been selected, this will change to be a Hide Properties button instead. Use this option to close the Properties window.

Browser View Tab

The Browser View displays a view of the content as it would be seen in a web browser for a selected node. It is also available if selecting a single item in the Items View. When selected, this tab will display a fully functioning web browser view of the selected content. You can use this Browser View to navigate or work with their content, the same way they would through a normal web browser window.

Browser View

Jobs List

Jobs in Metalogix Content Matrix Console can be managed from the Job List. Jobs are listed for migration actions that have already been run, as well as for actions that have been saved.

Jobs List

Using Multi-Select

Multi-select can be used to select a number of nodes on the source side Explorer View tree, and migrate those nodes to a target SharePoint instance. Multiple SharePoint connections can be selected at one time, but only to Disconnect or Refresh those connections. If connected to a SharePoint farm or web application, only a single site collection can be selected at a time, however, multi-select can be used on any sub-sites under a single site collection.

This feature also works for migrating a single list or site into multiple target locations at the same time; for example, if you have a document library that you want to migrate into two or more target SharePoint sites. After the library is copied, any number of desired target sites can be selected, as long as they are all under the same target connection node, and when pasted the list will be migrated to all of the selected target site nodes. The basic cases for multi-select are copying: multiple to one, one to multiple, and multiple to multiple.

For example, if an eRoom facility is selected in the Explorer View, and the navigation tree is expanded, you can select a number of rooms (Room A, Room B, etc.) and these can all be migrated at the same time. After pasting the content all the selected content (Room A, Room B, etc.) will be migrated under the target SharePoint node.

eRoom Multiselect

In addition to using check boxes to multi-select, you can use <Shift> and the <Ctrl> keys in the conventional way.

Limitations of Multi-Select

There are a few limitations when using multi-select. These limitations are:

·Only one node type can be selected at a time - This means that if a SharePoint site node is selected, then only other site nodes can be selected, and included in the action.  

While the content under those nodes will be migrated (as per the selected options), only other site nodes themselves can be selected. This is the same for SharePoint lists/libraries, and folders. When connected to a SharePoint server only a single site collection can be selected at one time, but multiple sites under the site collection level can be selected.

If an eRoom connection type is made, only nodes under each specific connection can be selected at one time. This means that users cannot select a facility node under two separate connections at the same time. While the content under the selected connection node will be migrated (as per the selected options), only other eRoom nodes of the same type, and under that same connection, can be selected at one time

The first node selected in the multi-select will determine what type of node can be included, and if an invalid selection is made, then the node that you tried to select will only blink. For example, if a list is selected, then only other lists, within the site collection, can be selected. If you try to select a SharePoint folder or site, then this is an invalid selection, and the folder or site will blink.

·Column Mapping - Column mapping is not available in some cases when using multi-select. If multiple lists are selected (on the source or target) then the Column Mapping feature will not be available. Column mapping is only available when migrating eRoom facilities or rooms, and will not be available if migrating items or other content types (such as Databases, calendars, etc.).

·Available Context (Right-Click) Menu Options - When using multi-select the options that are available in the context (right-click) menu can change depending on where the multi selection is taking place.

When copying multiple nodes from the source, only a few context menu options are available. For example, if migrating multiple eRoom rooms, then the following options would be available: Copy Containers and Refresh Nodes. If only one source item is selected and pasted to multiple locations, a few more of the Paste context menu options become available.

관련 문서

The document was helpful.

평가 결과 선택

I easily found the information I needed.

평가 결과 선택