Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Copy jobs work when created manually, but do not run when scheduled
설명
Copy jobs work manually, but do not start when scheduled.
원인
In newer operating systems (Windows Vista or later) the password for the scheduled task must be entered in the Windows Scheduled Task Manager
In some operating systems where the user is not logged in under an administration credential, the copy job will by default created to run as 'System'
Issues with Windows Task Scheduler
해결 방안
The credential used for the scheduled task can be seen in the properties of the job in the Microsoft Windows Scheduled Task Manager on the "General" tab. Click the button to "Change User or Group" and verify that the job is set to run under a credential that is at minimum a Local Administrator on both the Source and Target machines of the copy job. When closing the window, the user is prompted for a password. Make certain to enter a valid password for the Administrative credential. Note: When creating new scheduled tasks from Secure Copy, do not select the checkbox "Do not store password". You will be prompt for the password for the account when you click the OK button.
In some environments where the user is logged in as a non-administrative credential, or as a user that does not have administrative privileges on the Source and Target, the scheduled task will be created to run within the context of 'System'. Unless the Source and Target of the copy job are local storage systems on the box where Secure Copy is installed, change the user account to an account that has local Administrator and Backup Operators rights on both Source and Target volumes and enter a valid password for that account
Check history tab of the Scheduled Task in Windows Task Scheduler for any error message or codes. Create a test job using the same credentials as the SC task, however scheduling to run a different executable (such as Notepad.exe), to help confirm that the issue is specific to Secure Copy and not a problem with Windows Task Scheduler.