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Browsing the Databases in the Exchange Plug-in is not possible
설명
Browsing the Databases in the Exchange Plug-in is not possible and NetVault's WebUI returns the error "Failed to get the list of databases on server".
원인
If PowerShell's executionpolicy is not set to either RemoteSigned or Unrestricted, the list of databases running on the Exchange Server cannot be retrieved. To retrieve the databases of the Exchange Server, NetVault creates temporarily a PS script. If it's not possible to run this script, the warning "Failed to get the list of databases on server" is issued by the WebUI.
The same warning message might appear, if DNS mappings are not correctly setup. It has been observed that a misconfigured IPv6 DNS mapping can also issue the same warning in the WebUI.
해결 방안
1. This can either be a problem with the PowerShell executionpolicy on the Operating System on which the Exchange Server is running: To be verified with: Get-ExecutionPolicy -list Result should be for LocalMachine: Unrestricted or RemoteSigned
2. DNS resolution is not properly setup: Name to IP mapping must be correctly setup for IPv4 and if applicable for IPv6 as well. Check DNS settings with forward and reverse lookup:
From the NetVault Server's Operating System check reverse DNS lookup to the Exchange System with: ping -a a.b.c.d e.g. ping -a 10.10.20.1 Verify if DNS matches
Forward lookup: nslookup -a name e.g. nslookup ese.questlab.local Verify if returned IPv4 and IPv6 addresses are matching
If the NetVault Server's Operating System is not joined to the Domain, also check the host file (C:\windows\system32\drivers\etc\hosts). Test forward lookup.