When attempting to Mailbox enable accounts with the Notes Migrator for Exchange the following error is encountered in the log file:
ERROR: [7429-1-22-00000000] Unable to create mailbox for 'User@test.net'
Single object not found in AD.
Cause 1:
There is more than one object in the target environment (Exchange) with the same TargetAddress. Perhaps there is a contact for the Notes user in Exchange created by Migrator for Notes to Exchange (MNE) or Coexistence Manager for Notes (CMN).
Cause 2:
In this case, even though only one object exists for the User already and the proxyAddress does not appear on any other objects. This error can occur if the User account(s) being mailbox enabled have been created in Active Directory with the "Copy" method from a mailbox enabled User Security Object. Even though the new account has not been mailbox enabled when it was created it still has Exchange Attributes which interfere with the mailbox enable process Notes Migrator is using.
Resolution 1:
Run the MNE Provision process to merge the Exchange contact and the user object into a single user object.
Resolution 2:
1.) Attempt the mailbox creation manually to verify that there are no environmental issues.
2.) Verify that the migration account has the appropriate rights in the Active Directory environment.
3.) Consider removing a problem user from Active Directory then using the Notes Migrator for Exchange Merge "Create user objects in Active Directory" feature to create the object and attempt the mailbox enable process again.
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