When trying to reconstruct stubbed messages with the Exchange Utility, it fails with the following error in the ExchangeUtility.wlog:
Assign the account being used to reconstruct stubbed messages as an administrator in Archive Manager by:
-Go to the Logins tab in the administration console of Archive Manager
-Identity the login being used to reconstruct the stubbed messages and edit it
-Change the Security Role to 'Administrator'
-Hit update and try re-running the reconstruction with the Exchange Utility
Note: You can use the following query against the Archive Manager database to see if the account being used has permissions:
exec dbo.MessageSelect @LoginID=<the login Id used to access AM>, @CheckSum=<issue message checksum>
The results should show the message details. If the query completes successfully and does not display the message details, then the account does not have proper permission to view the message and the Exchange Utility will be unable to reconstruct the stubbed message.