This article is a supplement to the List of Known Issues provided in the Recovery Manager for Exchange 4.8.0 Release Notes. For each issue, the article includes an ID (TF number), a brief description of the problem, and a workaround.
TF00102193, TF00103292, TF00104493
Your attempt to register an Exchange Server database may fail with the error The stub received bad data. This problem occurs when Recovery Manager is installed on a Windows 7- or Windows Server 2008 R2-based computer.
WORKAROUND
Install Recovery Manager on a computer running any other supported operating system except Windows 7 or Windows Server 2008 R2, and then retry the storage registration operation.
TF00103865
When attempting to catalog removable storage media by using the Microsoft Removable Storage library option in the Catalog Wizard, you may receive the Class not registered error message that fails to describe the problem properly. In the situation in question, this error message indicates that the Removable Storage Manager (RSM) feature is disabled on the Recovery Manager computer.
WORKAROUND
Enable the Removable Storage Manager (RSM) feature on the Recovery Manager computer.
TF00104749
The French- and German-language versions of the User Guide erroneously include information about the Web Interface feature that has not been implemented in this release of Recovery Manager.
WORKAROUND
Disregard the information provided about the Web Interface feature in the French- and German-language versions of the User Guide.
TF00104880
After upgrading Recovery Manager to a newer version, you may observe the following unexpected behavior on the Logging tab in the Settings dialog box: The log files location is unexpectedly reset to the default value.
WORKAROUND
After upgrading, go to the Logging tab in the Settings dialog box to check whether or not the log files location has changed. If necessary, change the log files location as needed.
TF00104950
Unexpected behavior when Recovery Manager and Exchange Server are installed on the same computer: After your attempt to start Exchange Server emulation, Recovery Manager may fail to display a warning message stating that Exchange Server emulation is not supported for the mentioned configuration.
WORKAROUND
Running Exchange Emulation in the mentioned configuration can result in corruption of your Exchange Server and/or Active Directory environment. Do not start Exchange Server emulation when Recovery Manager and Exchange Server are installed on the same computer.
TF00105183
The detailed description provided in the Cmdlet Help topic for the Get-RMEMessage cmdlet erroneously mentions the Get-RMEMailbox cmdlet.
WORKAROUND
Disregard the fact that the Get-RMEMailbox cmdlet is mentioned in the topic. The topic should mention the Get-RMEMessage cmdlet.
TF00105190
You may encounter the following non-existing parameter when viewing Example 2 in the Cmdlet Help topic for the Attach-RMEExchangePublicFOlders cmdlet:
MailboxDn
WORKAROUND
The correct name of the parameter in question is MailboxName.
TF00105923
Your attempt to view the contents of a live mailbox registered with Recovery Manager may fail with the following error: Could not connect to mailbox <mailbox details>. Details: Undefined MAPI error. Detailed description is not available. This problem occurs when Recovery Manager is installed in the environment where Internet Protocol Version 6 (TCP/IPv6) is enabled.
WORKAROUND
Disable Internet Protocol Version 6 (TCP/IPv6) in the environment where Recovery Manager is installed.
TF00106364
You may receive the error Container is not searchable when using the Attach-RMEExchangeMailbox cmdlet to connect to a live Exchange Server mailbox to be used as a source storage.
WORKAROUND
The operation in question is not supported by the Attach-RMEExchangeMailbox cmdlet.
To connect to a live Exchange Server mailbox to be used as a source storage, use the following combination of cmdlets:
Get-RMEExchangeServer <parameters> | Get-RMEMailbox <parameters>
TF00106635
You may encounter the following non-informative error message while upgrading Recovery Manager: Failed to execute SQL string.
WORKAROUND
In the situation in question, this error message indicates that you have specified an unsupported version of Microsoft SQL Server. Specify one of the SQL Server versions supported by Recovery Manager (see the System Requirements section in the Recovery Manager Release Notes).
TF00107872
You may encounter any or all of the following problems while running an automated task that restores data from offline Exchange Server database (.edb) file:
- The task terminates prematurely.
- Recovery Manager stops responding.
WORKAROUND
If the Recovery Manager computer is running a 32-bit edition of Windows:
1. Create a .bat file containing the following text:
StoreHost.exe /RegServer
regsvr32 /s StoreHostps.dll
regsvr32 /s ExchDbps.dll
regsvr32 /s ExchDb.dll
2. Run the .bat file on the Recovery Manager computer.
If the Recovery Manager computer is running a 64-bit edition of Windows:
1. Create a .bat file containing the following text:
StoreHost64.exe /RegServer
StoreHost.exe /RegServer
regsvr32 /s StoreHostps.dll
regsvr32 /s ExchDbps.dll
regsvr32 /s ExchDb.dll
regsvr32 /s StoreHost64ps.dll
regsvr32 /s ExchDb64ps.dll
regsvr32 /s ExchDb64.dll
2. Run the .bat file on the Recovery Manager computer.
TF00108011
Your attempt to start Exchange Server emulation may permanently fail in a scenario where Recovery Manager and BakBone NetVault Server 8.1 are installed on the same computer.
WORKAROUND
Make sure that Recovery Manager and BakBone NetVault Server 8.1 are installed on different computers.
TF00108087
Your attempt to directly access Exchange Server backups created with EMC Legato NetWorker 7.4.4 may permanently fail with the error Column ID is constrained to be unique.
WORKAROUND
To register storages from such backups, use the instructions provided in the Working with EMC Legato NetWorker section in the Recovery Manager User Guide.
TF00108926
Your attempt to use Exchange Server emulation to register a storage from a snapshot backup created with BakBone NetVault 8.2 may fail with the error Failed to restore database Mailbox Database. This problem occurs when you are using Recovery Manager on a Windows Server 2003- or Windows XP-based computer.
WORKAROUND
Install and use Recovery Manager on a computer running Windows 7, Windows Server 2008 R2, Windows Server 2008, or Windows Vista.
TF00109872
Your attempt to catalog a tape containing backups created with Symantec Backup Exec 12.0 may fail with the following error: Unable to open the device <Device> The process cannot access the file because it is being used by another process.
WORKAROUND
Use the Exchange Server Emulation feature to extract Exchange Server databases from the backups and then register these databases with Recovery Manager.
TF00110152
Your attempt to use the Exchange Server Emulation feature to extract and register Exchange Server databases from backups created with CA BrightStor ARCserve Backup 12.5 may permanently fail. This problem occurs when Recovery Manager and ARCserve Backup 12.5 are installed on the same computer and the ARCserve Backup Manager window is open while you are performing the storage registration operation.
WORKAROUND
Follow these steps to register storages:
1. Start Exchange Server emulation.
2. Restart the ARCserve Backup Manager.
3. Proceed with the storage registration operation.
TF00110527
The Whats New document for Recovery Manager version 4.8 fails to mention that Recovery Manager can restore data to online Exchange Server 2007 SP2 and Exchange Server 2010.
WORKAROUND
Disregard the fact that this functionality is not mentioned in Whats New. Recovery Manager does support restoring data to online Exchange Server 2007 SP2 and Exchange Server 2010.
TF00111113, TF00111116
You may encounter the error ERR - unable to create object to restore when all of the following conditions are true:
- You run Exchange Server Emulation to extract and register Exchange Server 2007 databases from a backup created with Veritas NetBackup 6.5.4.
- CCR (Continuous Cluster Replication) is enabled on the Exchange Server 2007 whose databases you attempt to extract and register.
WORKAROUND
1. Use the Exchange Management Shell on the Exchange Server 2007 computer to suspend replication.
2. Retry to extract and register the databases.
Defect ID:
TF00102193, TF00103292, TF00103865, TF00104493, TF00104749, TF00104880, TF00104950, TF00105183, TF00105190, TF00105923, TF00106364, TF00106635, TF00107872, TF00108011, TF00108087, TF00108926, TF00109872, TF00110152, TF00110527, TF00111113, TF00111116