Issue
When I start migration of some Notes mailboxes, the migration worker returned an error message: Autodiscover result has no EXCH protocol, Autodiscover works correctly. The mailbox is MAPI enabled. The migration account has "Full Access" permissions to each mailbox
@ 18:00:40 Calling autodiscover application: "C:\Program Files (x86)\Binary Tree\CMT for Exchange\Worker\OutlookAgent32.exe" -address user.name@domain.sk -user "namef@domain.sk" -password "*********" -type mailbox -profile "CMT Temp Migration Profile" -l "C:\Users\namejf\AppData\Local\Binary Tree\Notes Migrator\BTautodiscover.log"
@ 18:02:04 Begin AutoDiscover and Profile Creation Log
18:02:04 6:00 PM: [Info] Using Exchange credentials from registry
18:02:04 6:00 PM: [Info] Logging in with: name.sk@domain.sk
18:02:04 6:02 PM: [Error] Exception in BTLogonHostedExchange:
18:02:04 6:02 PM: [Error] Unable to logon to Hosted Exchange Mailbox: user.name@domain.sk
@ 18:02:04 End of AutoDiscover and Profile Creation Log
18:02:04 AutoDiscover Response for Mailbox not found C:\Users\tx200jf\AppData\Local\Binary Tree\Notes Migrator\
Cause
The SMTP Address and UPN of the migration account is not the same, and the UPN is not a routable domain, Connectivity tester works but the autodiscover does not if the UPN in a non-routable domain.
Migrations report an error initializing if the Connectivity Tester is used to set an autodiscover account that has a valid SMTP address (with CNAME) but a UPN that is an AD only domain.
The connectivity tester works correctly in this case but the Outlook32 agent used for the connection has the UPN specified only as the user and this results in the failure if the UPN does not have an autodiscover configuration.
This for Office 365 and On Premise migrations.
Example:
Connectivity tester configured with:
SMTP: Local.UPN@corp33.cmtsandbox.com
UPN: Local.UPN@onprem.corp33.cmtsandbox.com
Migration fails with:
@ 20:35:06 Calling autodiscover application: "C:\Program Files (x86)\Binary Tree\CMT for Exchange\Worker\OutlookAgent32.exe" -address user.name@corp33.cmtsandbox.com -user "Local.UPN@onprem.corp33.cmtsandbox.com" -password "*********" -type mailbox -profile "CMT Temp Migration Profile" -l "C:\Users\o365.Admin\AppData\Local\Binary Tree\Notes Migrator\BTautodiscover.log"
@ 20:35:11 Begin AutoDiscover and Profile Creation Log
20:35:11 8:35 PM: [Info] Using Exchange credentials from registry
20:35:11 8:35 PM: [Info] Logging in with: Local.UPN@corp33.cmtsandbox.com
20:35:11 8:35 PM: [Error] Exception in BTLogonHostedExchange:
20:35:11 8:35 PM: [Error] Unable to logon to Hosted Exchange Mailbox: user.name@corp33.cmtsandbox.com
@ 20:35:11 End of AutoDiscover and Profile Creation Log
20:35:11 AutoDiscover Response for Mailbox not found C:\Users\o365.Admin\AppData\Local\Binary Tree\Notes Migrator\user.name@corp33.cmtsandbox.com-AutoDiscover-Mailbox.xml
! 20:35:11 Error: AutoDiscover Mailbox LegacyDN not found.
! 20:35:11 Error: Failed to initialize : User Name
@ 20:35:11 Entering UnInitialize MAPI Object
! 20:35:11 Error: AutoDiscover Mailbox LegacyDN not found.
In this case if the UPN domain is added to a Hosts file with the relevant autodiscover then the migration does proceed. eg 00.00.000.000 autodiscover.onprem.corp.cmtsandbox.com
In these cases the SMTP address cannot be used as the UPN as the connectivity tester fails to connect.
Solution
Add the UPN value to the SMTP email addresses for the account in Exchange
Use the migration account's NetBIOS domain pre Windows 2000. when configuring the autodiscover in the migration workstation installation wizard, and/or the Connectivity Tester
If the UPN is the same, then check the Binary Tree auodiscover connectivity tester on each migration workstation, perform a test, and confirm the credentials are correct and still pass. If they fail, enter the correct credentials, and save.
Restart the migrations.
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