A "Socket Closed" or "Timeout expired" error occurs from the SQL Server JDBC driver connects to a SQL Server instance.
CAUSE 1
The Foglight Agent Manager used a Java version 1.6.34 this caused a connectivity bug as described in http://support.microsoft.com/kb/2653857
CAUSE 2
The database agent is attempting to use an unencrypted connection to connect to an instance which is configured to use SSL.
CAUSE 3
The Timeout expired error occurs when the driver's default cryptographic protocols do not match the database's cryptographic protocol. The Socket closed error occurs when the driver's cryptographic protocol matches that of the database but the OS on which the database is installed is not set up to accept that protocol. This is described by Progress (the maker of the JDBC driver used by the cartridge here)
RESOLUTION 1
Apply the latest Microsoft service packs to the Operating System.
RESOLUTION 2
Configure the SQL Server agent to connect to the database instance using SSL.
RESOLUTION 3
Export the settings from the Protocols registry key and below, then engage Support to review the security protocol settings on the host.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols]
© ALL RIGHTS RESERVED. Terms of Use Privacy Cookie Preference Center