Date - June 2009
Affected Product & Version - NetVault: Backup 8.x
Affected Module & Version - Exchange Server APM v4.x
OS Version - Windows 2003 and 2008
Application Information - Exchange 2007
Symptoms:
Although Exchange backups are successful, when restoring (to RSG or directly), the job fails rapidly with the following errors messages:
Binary log:
Job Message 2009/06/10 16:01:17 128 Data Plugin UKW1906 Restore stream ready for Storage Group Third SG
Error 2009/06/10 16:01:17 128 Data Plugin UKW1906 Failed to start restore for Storage Group 'Third SG'
-------An error occurred:
------------Callback
Job Message 2009/06/10 16:01:17 128 Data Plugin UKW1906 Restore stream close for storage group Third SG
Error 2009/06/10 16:01:17 128 Jobs UKW1906 Fatal error: Restore failed
Trace from nvexchange_restore_slave process :
1 EXCHRESS:0740 1080 0 145528 Opening UKW1906, service Microsoft Information Store, to restore Third SG, using temp directory 'C:\WINDOWS\tmp\NVBU\Third SG'
1 EXCHUTIL:0740 700 0 145528 Method ExchangeEtkCheckHrIfSuccess: starts
1 EXCHUTIL:0740 928 0 145528 ExchangeEtkCheckHrIfSuccess: hrLast = 5.GetLastError() = 1008
1 EXCHUTIL:0740 642 0 145528 Message return value: 'Callback'
1 EXCHUTIL:0740 699 0 145528 Method ExchangeEtkCheckHrIfSuccess: ends, success = FALSE
0 EXCHRESS:0740 1081 0 145528 Failed to open restore for Storage Group 'Third SG' with error 'Callback'
Cause:
Trace shows that we successfully login to the Exchange Server.
We then check for the presence of the temporary space and any files in it (ie restore.env).
When ready to restore we try to open the Exchange server for the ESE Restore request and fail.
This is because the NetVault Process Manager service on the Exchange Server is not running as Local System Account.
An engineering fault
- Check the NetVault Process Manager service in Windows
- Make sure it is running as Local System Account.
- restart the NetVault Process Manager service
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