Date: Jul 2009
Product & Version: NVBU any
OS Version: any
Module & Version: Report Producing Module
Application version:na
Symptoms:
Reports fail with:
Failed to run report job. The returned error was:
Failed when running job to produce output. Please see job log.
Further information in the log shows:
Cannot gain access to client machine.
Fatal error: Failed to start plugin
When trying to save a job after editing the following error is generated:
"Error Saving Job "xxxxxx"
Suspicious Job, not allowed to submit.
Cause:
This is normally seen after a Netvault database is restored to a new server with a different Netvault name. The internal job definitions for the report jobs still refer to told Netvault Server name and these jobs must be recreated from scratch.
The first run of a report job in these circumstances causes the job to hang in a running state, subsequent jobs fail with the errors noted above.
Note: If custom reports are in place, these can be saved before the recreation procedure then reinstalled afterwards, please refer to Solution 4009: "How to export/import custom reports using template files".
1. Launch the Reporting Module.
2. Bulk select all the reports then use right click -> delete. Ensure that all reports are removed.
3. Select Client Management and right click on the NetVault server. Select to Remove Software then uninstall the Report Producing APM.
4. Again in Client Management, Right click on the NetVault server. Select to Install Software and browse to the following path: netvault/packages/standard and select the file named rptxxx.npk (the exact name depends on the version and platform)
5. Open a command prompt and navigate to the netvault/util directory
6. Run the following utility: nvaddcannedreports
7. Any custom reports need to be re-added after this procedure