Date: 16 May, 2006
NV Version: All
OS Version: All
Application version: n/a
Plugin version: n/a
Description:
Jobs finish with a state of "Backup Completed with warnings", and contains many "Error reading file" entries in the log.
Symptoms:
Backup jobs, particularly on Unix-like operating systems, may finish with a status of "Backup Completed with warnings" and contain many "Error reading file" entries in the log.
Cause of problem:
Many types of files on Unix-like operating systems will generate errors when an attempt to back them up is made. This is caused by Unix-like operating systems addressing many objects as "files"; these "files" can not be read using filesystem calls/methods and therefore can not be backed up. Examples of such "files" are - sockets, "Door files", and files in the '/proc' and '/sys' filesystems.
Note that temporary files may also generate errors during backup. This is due to NetVault building an initial index of files to include in a given backup, and temporary files being removed by the operating system or an application during the backup.
After careful consideration exclude temporary files from backup, as well as the '/proc' and '/sys' filesystems if appropriate. Some subdirectories of '/var' may also be excluded (seek the advice of a senior system administrator before excluding such directories from backup jobs). For more information about excluding files from backup please refer to Chapter 17 of the NetVault Administrator's Guide.