Date: 05/2012
Affected Product & Version - NetVault Backup
Affected Module & Version - n/a
OS Version – Windows
Application Information – n/a
現象/不具合内容:
NVBUクライアントから CLIコマンドを実行するときに -server オプションを使用するものがあります。このオプションを使用してCLIコマンドを実行すると下記例のメッセージが出力されCLIコマンドが失敗することがあります。
例)
nvreport -server サーバ名 -class "Job History"
Failed to initiate a CLI session on server "サーバ名"
- CLI プロキシを接続することができませんでした- '%s' セキュリティアクセス失敗
原因:
NVBUクライアントから -server オプションを付けてCLIコマンドを実行すると、NVBUサーバ上ではCLI Proxy(cliproxy.exe) が起動されます。NVBUサーバにてWindowsファイアウォールの設定を行っているとNVBUクライアントからのCLI Proxyの起動が拒否されるため、本メッセージが出力されCLIコマンドが失敗します。関連ソリューション#4309のスクリプトにはCLI Proxyのファイアウォールを除外する記載が無いため、関連ソリューションのスクリプトを適用している環境でも本事象は発生します。
対処方法:
下記例のように NVBUサーバ側でWindowsファイアウォールの除外設定を行ってください。
例)
Windows XP Professional/Windows Server 2003をご利用の場合
netsh firewall add allowedprogram program = %NVPATH%\cliproxy.exe name = "NetVault CLI Proxy" mode = ENABLE profile = ALL
Windows Vista/Windows Server 2008をご利用の場合
netsh advfirewall firewall add rule name="NetVault CLI Proxy" dir=in action=allow program=%NVPATH%\cliproxy.exe" enable=yes
※ %NVPATH%は NetVault インストール・ディレクトリ以下bin ディレクトリ
関連ソリューション:
Windowsマシン上のWindows FireWall機能を有効にするとバックアップが失敗する
ソリューション番号:108123 (https://support.quest.com/jp/kb/SOL108123)
Microsoft Windowsのファイアウォール環境でNetVault Backupを使用するには
ソリューション番号:108440 (https://support.quest.com/jp/kb/SOL108440)
ソリューション番号:6507