Snapshots fail with an error saying "A call to a remote server timed out"
If you watch the backup, the transfer will sit in "Determining data to send," then fails.
In the Configuration/Settings area, scroll down to Replay Engine Configuration and set the Connection Timeout and Read Write Timeout values to 20 minutes, the maximum that can be configured. Stop and restart the AppAssure service. How To Stop or restart the Core Service (4034348) (quest.com)
If the backup still fails after 20 minutes of "Determining data to send," stop the service, open regedit and locate the key HKLM\Software\AppRecovery\Core\CoreSettings\ClientTimeOutSettings. Change the ConnectionTimeout and ReadWriteTimeout values to a large value. This may very well require that they be set to something greater than an hour. The format of the registry values is HH:MM:SS.