Trying to create two sessions from Toad, the second session always give the error "ORA-28547 connection to server failed". The first connection is good. If two different TOAD windows or instances are opened, both connect fine as well.
The error can also occur by just connecting a single Toad to the database.
ERROR:
ORA-28547: connection to server failed, probable Oracle Net admin error
CAUSE 1:
Two or more connections or session are causing the issue.
CAUSE 2:
The Database is not Started.
RESOLUTION 1:
1. Fully exit Toad
2. Start Toad and connect to one database only
3. Fully exit Toad via File menu | Exit
4. Start Toad again and re-test the issue
RESOLUTION 2:
1. Fully exit Toad
2. Rename file toad.ini in C:\Documents and Settings\<username>\Application Data\Quest Software\Toad for Oracle\9.7\User Files
3. Launch Toad and run the setup process again - ensure "Allow multiple copies of Toad to be loaded” is checked
4. Make one connection
5. Fully exit Toad again
6. Re-launch Toad and try two or more connections
RESOLUTION 3:
1. Fully exit Toad
2. Start Toad and connect to one database.
3. Go to View | Toad Options | Startup | Check "Allow multiple copies of Toad to be loaded" | select Apply
4. Open another Toad program or instance - Start | Programs | Quest Software | Toad for Oracle | Toad for Oracle 9.7
5. On this second Toad instance, connect to the second database
6. Close the second Toad instance
7. Close the first Toad instance
8. Open Toad and connect to the first database then to the second database using only this single Toad instance
RESOLUTION 4:
If you are connecting a single Toad instance only (only one Toad is open; no other Toad is connected to the db), the Database server may be Stopped or offline. Go to the machine where the db resides, then go to the Windows Services, and then start the database i.e. right-click 'OracleServiceORCL' and choose 'Start'.