Chatta subito con l'assistenza
Chat con il supporto

Metalogix Content Matrix 9.4 - Public Folder Edition User Guide

Introduction Entering the License Key Selecting the SQL Database You Want to Connect to Content Matrix Console End User Interface Connecting to Public Folders Connecting to SharePoint Preparing for Your Migration Initiating a Migration Configuring Copying Options Saving or Running a Migration Action Log Files Using PowerShell with Content Matrix Modifying Content Matrix Configuration and Settings Frequently Asked Questions About Us

Saving or Running a Migration Action

When you finish configuring a migration action, you can run it immediately or save a copy of the settings to a job file, which displays in the Job List section.  You can then:

·run a migration directly from the Job List section

OR

·create a PowerShell script and schedule it to run as a Windows Scheduled Task

OR

·trigger jobs in the Content Matrix Console to run using PowerShell.

You can also save the job configuration as a template so that you can preserve and reuse settings for future migration jobs.

When the migration starts, a status dialog box will appear. The job logs can be viewed (in progress or after the migration is finished) by clicking [Details>>]. The Status section of the status box will list a live count for the number of successes, warnings, failures, etc. for the migration. The Progress section of this dialog will list any completions and the type of completion (Sites, lists, items, users, groups, etc.). A Migration Completed message will appear when finished. Click Close to exit the status dialog.

IMPORTANT:  As of version 9.2, Distributed Migration has been removed from Content Matrix Public FolderEdition, and you will no longer have the option to Run Remotely.

Connecting to a Full SQL Job Database

If you are using SQL CE to host your Content Matrix Jobs Database, you will receive a warning in the job log (and as a pop-up if you are running the job from the Console interface).

The use of SQL CE in a production environment is discouraged because of the following limitations:

·It uses a single .list file that is less robust and reliable and may be corrupted after the database reaches 4 GB.

·Data compression is not supported.

·Support for large objects is limited.

To switch to a full-feature SQL Server for the Content Matrix Job Database:

1.From the Job List choose File > Connect to Job Database.

Switch Jobs Database

2.Complete the Connect to SQL Server dialog.  Create (using the New Database option) or select the database you want to use.

Select Jobs Database

If you want to use an encrypted connection to the database, check the Encrypt Connection box.

NOTE: If the certificate used for encryption is not trusted, you will also need to check the Trust Server Certificate box.

Saving a Job Configuration as a Template

You can create job configuration templates for a set of selected settings which can be saved and reused, including any options that are not normally preserved using the Preserve Configuration Options option (in the ribbon Settings menu).

These templates can also be moved to another machine and used with a separate install of Metalogix Content Matrix Console (provided that it is the same Edition of Metalogix Content Matrix, and the same version number or greater).

To save a job configuration template:

1.After initiating a migration, complete the Configure (Object) Copying Options with the settings that you want to include in the template.

Sve Job Configuration dialog

2.Click [Save Job Configuration].

Here you can set the display name for the job template. This is not the actual file name, but it is the name that Metalogix Content Matrix will use to list the template.

NOTE: In most cases, when a job template is saved by Metalogix Content Matrix it will be saved to the following location:
C::\Users\<User>\AppData\Roaming\Metalogix\Metalogix Content Matrix Console - <Product> Edition

However, it is highly recommended that you do not interact with this system location. If you are trying to save a job template so it can be exported to another system the template can be exported from the Manage Job Configurations dialog.

3.Enter the desired display name value and click [OK] to continue.

Once the save is complete, you will be returned to the Configure <Object> Copying Options dialog where the migration can either be Run or Saved.

The saved job templates will now be visible in the Manage Job Configurations dialog.

NOTE: If you are looking to save a job template and move it to another system for use, this should be done using the Export option in the Manage Job Configurations window. Additionally, if you are trying to Import a job template from another system, this must also be done from either the Manage Job Configurations dialog or it can be imported when applying a template.

Applying a Job Template

Any job templates that have been imported or saved, and are available in the Manage Job Configurations dialog can be applied to another migration of the same type. For example, if migrating at the site level, you would not be able to use a job template that is created for a migration at the list level. It would only be able to use a template that migrates at the site level.

The source and target connection types do not apply directly to a job template, so it does not matter if the connection types for the new migration are the same as the connection types for the job template. If the connection types are different than any options that are not applicable for the connection types that are being used will not be available, but all other options will be set.

1.After initiating a migration, click [Open Existing Job Configuration] in the bottom left corner of the Configure <Object> Copying Options dialog to display the Select Job Configuration to Apply dialog.

NOTE:  Any options you have specified directly in the dialog will be overwritten once a job template is applied.

Select Job Configuration to Apply dialog

The  dialog lists all of the job templates that are currently available for the migration type (i.e. a site, list, item, etc. migration), as well as only the templates for the specific Edition of Metalogix Content Matrix that is being used.

2.Select the desired job template and click [OK].

You will be prompted to confirm your action before continuing.  Remember that if you choose to apply the template, any other settings that you entered directly in the Configure <Object> Copying Options  will be lost.

The Configure <Object> Copying Options dialog will now reflect all of the template options. Any additional configuration options can be set or modified, and the migration can continue as normal.

Related Documents

The document was helpful.

Seleziona valutazione

I easily found the information I needed.

Seleziona valutazione