Issue
Worker Connection test fails - Exception connecting to default folder: Error in IMAPISession::openMsgStore: MAPI_E_LOGON_Failed
Cause
We uninstalled 3.8.2 and installed Notes Migrator 4.6.3. However the migration workstation fails during the Exchange connectivity test. Registry key for MapiHttpDisabled was set to 0.
Confirmed that Autodiscover is working. Exchange is setup in Hybrid mode. Outlook is configured correctly with same account. Error below.
Exception connecting to default folder: Error in IMAPISession::OpenMsgStore: MAPI_E_LOGON_FAILED
Make sure your code runs under the Windows user identity that has MAPI profiles.
When running in a service (including ASP under IIS), set your code to run under
the Windows user account that has MAPI profiles.
When connecting to an Exchange Server, you can also use RDOSession.LogonExchangeMailbox
which does not require an existing profile.
ulVersion: 0
Error: The information store could not be opened.
Component: MAPI 1.0
ulLowLevelError: 0
ulContext: 646
Solution
Make sure the migration workstation is not connecting to the external hostname of the Exchange Server using an IP address pointing to a load balancer.
Edit the migration workstation(s) Hosts file
Create an entry to resolve the external hostname to the internal IP of the Exchange server
Run the Connectivity Tester to confirm a successful connection to Exchange via autodiscover
If the test is still failing for an Exchange on-premise migration, the use the Microsoft Remote Connectivity Analyzer to test the connection.
© ALL RIGHTS RESERVED. Feedback Termini di utilizzo Privacy Cookie Preference Center