Issue
We received the following error when “Run O365 Validation Check” or "Enable/Activate Mailbox" is performed:
"OLE: Automation object error “
Cause
One or all of the following may caused this error:
- Inadequate O365 account permission
- Inadequate permissions to write to c:\logs, c:\matching, c:\activation and all directories PowerShell needs to write to
- Object is not found in AD, still a contact, must enable the object and assign it a license in O365
- UAC is enabled
- SKU ID is entered and when saving it changes the ":" to a "." they then go in manually to change it to correctly be a ":".
- SKU ID is entered incorrectly
Solution
This will be resolved in a future release
For previous versions, see the following solution
- Confirm Notes Migrator has been installed and configured per our requirements documentation. Ensure the PowerShell Modules are installed NM: Download Windows Azure PowerShell Module
- Confirm the Remote PowerShell URL field is set to "https://ps.outlook.com/powershell" in the "User Provisioning" tab.
- Validate 'full access' permissions to access the O365 account
- Validate permissions to write to c:\logs, c:\matching and all directories are adequate
- Validate the Object is found in AD and not a contact
- UAC - Disable
- Validate SKUID and associated license is correctly entered in the CMTe settings
- Make sure the workstation running the command does not have OLE or ActiveX controls disabled.
An updated agent 'BPOS O365 Validation' will provide more description in the PowerShell log. Please use this agent to diagnose.
cmte_o365_validation.nsf
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