Chat now with support
Tchattez avec un ingénieur du support

Recovery Manager for AD Forest Edition 10.0.1 - Release Notes

System Requirements

System requirements

Before installing Recovery Manager for Active Directory Forest Edition 10.0.1, ensure that your system meets the following minimum hardware and software requirements.

NOTE: Recovery Manager for Active Directory Forest Edition can backup and restore domain controllers that are running on virtual machines in Amazon Web Services (AWS) or Microsoft Azure.

Recovery Manager for Active Directory Forest Edition requirements

Table 8: Recovery Manager for Active Directory Forest Edition system requirements

Requirement Details
Processor

Minimum: 1.4 GHz

Recommended: 2.0 GHz or faster

Memory

Minimum: 1 GB

Recommended: 2 GB

These figures apply only if the Active Directory domains managed by Recovery Manager for Active Directory Forest Edition include 1 million objects or less. Increase RAM size by 512 MB for every additional 1 million objects.

Hard disk space

x86 system

Full installation including the prerequisite software: 1.5 GB of free disk space

In case all the prerequisite software is already installed: 250 MB of free disk space

x64 system

Full installation including the prerequisite software: 2.7 GB of free disk space

In case all the prerequisite software is already installed: 260 MB of free disk space

NOTE: Additional storage space is required for a backup repository, at least the size of the backed-up Active Directory database file (Ntds.dit) and the SYSVOL folder plus 40MB for the transaction log files.

Display SVGA at 1024 x 768 or higher
Operating system

NOTE: Machine that hosts the Recovery Manager for Active Directory console must have same or higher version of Windows operating system than the processed domain controllers. Otherwise, the online compare and object search in a backup during the online restore operation may fail.

Installation

  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2 with or without any Service Pack
  • Microsoft Windows Server 2012 with or without any Service Pack
  • Microsoft Windows Server 2008 R2 without Service Pack or with Service Pack 1
  • Microsoft Windows Server 2008 with Service Pack 1 or Service Pack 2
  • Microsoft Windows 10
  • Microsoft Windows 8.1 with or without any Service Pack
  • Microsoft Windows 8 with or without any Service Pack
  • Microsoft Windows 7 without Service Pack or with Service Pack 1
  • Microsoft Windows Vista with Service Pack 2

Targets for backup, restore, or compare operations

  • Microsoft Windows Server 2019 including Server Core installation
  • Microsoft Windows Server 2016 including Server Core installation
  • Microsoft Windows Server 2012 R2 with or without any Service Pack (including Server Core installation)
  • Microsoft Windows Server 2012 with or without any Service Pack (including Server Core installation)
  • Microsoft Windows Server 2008 R2 without Service Pack or with Service Pack 1 (including Server Core installation)
  • Microsoft Windows Server 2008 with Service Pack 1 or Service Pack 2 (including Server Core installation)

The Windows Server Backup feature is supported for Windows Server 2008 R2 or higher. Make sure that the feature is installed on all domain controllers in your environment.

Microsoft .NET Framework
  • Microsoft .NET Framework version 4.5.2 or higher
Microsoft SQL Server and its components

Microsoft SQL Server versions

One of the following version is required:

  • Microsoft SQL Server 2016 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)
  • Microsoft SQL Server 2014 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)
  • Microsoft SQL Server 2012 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)

Microsoft SQL Server components

Microsoft System CLR Types for SQL Server 2012
If this component is not installed, it will be installed automatically by the RMAD setup.

Microsoft SQL Server Reporting Services

To display reports, Recovery Manager for Active Directory Forest Edition can integrate with Microsoft SQL Server Reporting Services (SRSS) 2012, 2014 and 2016.

Microsoft Windows PowerShell Microsoft Windows PowerShell version 3.0 or later
Microsoft Windows Installer Microsoft Windows Installer 4.5
Microsoft Management Console Microsoft Management Console 3.0
Integration with ChangeAuditor for Active Directory To provide information on who modified particular Active Directory objects, Recovery Manager for Active Directory can integrate with ChangeAuditor for Active Directory from version 6.0 to 7.0.1.

If any prerequisite software is not installed, the Setup program automatically installs it for you before installing Recovery Manager for Active Directory Forest Edition. If the prerequisite software to be installed is not included in this release package, it is automatically downloaded.

Forest Recovery Agent requirements

Table 9: Component requirements

Requirement

Details

Processor 450 MHz or faster
Memory 256 MB (1 GB recommended)
Hard disk space

x86 system: 850 MB or more

x64 system: 2 GB or more

Display 50 MB or more
Operating system

One of the following operating systems:

  • Microsoft Windows Server 2019 including Server Core installation
  • Microsoft Windows Server 2016 including Server Core installation
  • Microsoft Windows Server 2012 R2 with or without any Service Pack (including Server Core installation)
  • Microsoft Windows Server 2012 with or without any Service Pack (including Server Core installation)
  • Microsoft Windows Server 2008 R2 without Service Pack or with Service Pack 1 (including Server Core installation)
  • Microsoft Windows Server 2008 with Service Pack 1 or Service Pack 2 (including Server Core installation)
Prerequisite software Microsoft Windows Installer 4.5 or later must be installed.

Active Directory Virtual Lab requirements

NOTE: Microsoft Windows Server 2019 is not yet supported as an operating system for source computers.

Table 10: Component requirements

Supported virtualization infrastructure

Requirements

Microsoft System Center Virtual Machine Manager (SCVMM) 2012 without Service Pack or with Service Pack 1

Software that must be installed on the Active Directory Virtual Lab computer:

  • Microsoft SCVMM Console (supplied with the SCVMM version you plan to use)

Software that is installed on the source computer by Active Directory Virtual Lab console:

  • Microsoft SCVMM Agent

Supported operating systems for the Hyper-V host:

  • Microsoft Windows Server 2008/2008 R2
Microsoft System Center Virtual Machine Manager (SCVMM) 2012 R2 or 2016

Software that must be installed on the Active Directory Virtual Lab computer:

  • Microsoft SCVMM Console (supplied with the SCVMM version you plan to use)

Software that is installed on the source computer by Active Directory Virtual Lab console. For for more details, see here:

  • Disk2vhd v2.01 utility

Supported operating systems for the Hyper-V host:

  • Microsoft Windows Server 2012 or higher.
VMware vCenter/ESX Server 5.0, 5.1, 5.5, 6.0 and 6.5.

Recovery Manager Portal requirements

Table 11: Component requirements

Requirement

Details

Processor 1 GHz or faster
Memory 512 MB or more
Hard disk space

x86 system: 850 MB or more

x64 system: 2 GB or more

Display SVGA at 1024 x 768 or higher
Operating system

You can install the Recovery Manager Portal on a computer running one of the following operating systems (both x86 and x64 platforms are supported):

  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2 with or without any Service Pack
  • Microsoft Windows Server 2012 with or without any Service Pack
  • Microsoft Windows Server 2008 R2 with Service Pack 1 or later
  • Microsoft Windows Server 2008 with Service Pack 2 or later
Web browser To access the Recovery Manager Portal, you can use Microsoft Internet
Explorer 8 or higher.
Microsoft .NET Framework Microsoft .NET Framework version 4.5.2 or higher
Microsoft Internet Information
Server (IIS)
Microsoft Internet Information Services (IIS) 8.5, 8.0, 7.5, or 7.0.
Microsoft SQL Server and its components

Microsoft SQL Server versions

One of the following versions is required:

  • Microsoft SQL Server 2016 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)
  • Microsoft SQL Server 2014 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)
  • Microsoft SQL Server 2012 with or without any Service Pack (Enterprise, Business Intelligence, Standard, Express, Web, or Developer Edition)

Required Microsoft SQL Server components

  • Microsoft System CLR Types for SQL Server 2012
    If this component is not installed, it will be installed automatically by the RMAD setup.

Password and SIDHistory Recoverability Tool

You can only use the Password and SIDHistory Recoverability Tool if Microsoft's Active Directory Recycle Bin is not enabled in your environment.

 

Product Licensing

Product licensing

The Recovery Manager for Active Directory Forest Edition license specifies the licensed number of user accounts in the Active Directory domains protected with the product. If the actual number of user accounts exceeds the licensed number, Recovery Manager for Active Directory Forest Edition does not stop functioning but displays a warning message each time you back up data. In this case, you need to purchase and install a new license key file allowing you to back up a greater number of user accounts or revoke licenses from the domains whose backups you no longer need.

To view information about and manage the installed license key file, you can use the License tab in the About dialog box: in the Recovery Manager Console, right-click the Recovery Manager for Active Directory console tree root, and then click About.

Installing license key file

You need to supply a valid license key file when installing Recovery Manager for Active Directory Forest Edition.

To install a license key file

  1. In the Setup Wizard, on the User Information page, click Browse license to display the Select License File dialog box.
  2. Locate the Quest license file (*.dlv) and click Open.

Updating license key file

If you have purchased a new license key file, use the Recovery Manager Console to update the license key file.

To update the license key file

  1. In the Recovery Manager Console, right-click the Recovery Manager for Active Directory console tree root, and then click About.
  2. In the About dialog box, click the License tab, and then click Install License File.
  3. In the Update License dialog box, enter the path and name of the license key file, and then click OK.

Revoking licenses

When the actual number of user accounts exceeds the licensed number, Recovery Manager for Active Directory Forest Edition returns a warning message each time you back up data. In this case, you can revoke licenses from the domains whose backups you no longer need. The revoked licenses are returned to the pool of available licenses and you can allocate them to a different domain.

Caution: When you revoke licenses from a domain, all backups created by Recovery Manager for Active Directory Forest Edition for that domain get deleted. You should only revoke licenses from a domain if you no longer need backups created for that domain.

To revoke licenses from a domain

  1. In the console tree, right-click the root node, and then click About.
  2. In the About dialog box, click the License tab.
  3. On the License tab, select the domain from the License Usage list, and then click Revoke.
  4. In the confirmation message box, click Yes.

Getting Started

Getting started

Upgrade and installation instructions

Recovery Manager for Active Directory Forest Edition 10.0.1 supports upgrade from version 8.6.1 or higher.

Starting from version 8.8, it is recommended to manually upgrade pre-installed Backup Agents to the latest version on every domain controller. For versions prior to 8.8, the upgrade of Backup Agents is required.

You have the option to perform the Forest Recovery operation using the latest product version together with Forest Recovery Agents version 8.8.1 without agents upgrade. To do this, take the following steps:

  1. Set the HKLM\SOFTWARE\Wow6432Node\Quest\Recovery Manager for Active Directory\DisableAgentVersionCheck (DWORD) registry key to 1.
  2. Make sure that the NTLM authentication is enabled in your environment.
  3. Switch the Forest Recovery Agents version 8.8.1 to the Negotiate authentication mode by removing the certificate (.pfx file) from the agent installation directory.
  4. Restart the agents.

Important: Upgrade from Recovery Manager for Active Directory Forest Edition version 8.6 is not supported due to specific installation and upgrade issues found in version 8.6. Those issues are resolved in versions since 8.6.1.

Therefore, if version 8.6 is installed, perform the following steps:

  1. Export the necessary scheduled backup creation tasks.
  2. Remove Recovery Manager for Active Directory Forest Edition 8.6 from your computer.
    Note that all you settings and data are preserved, except for scheduled backup creation tasks.
  3. Install Recovery Manager for Active Directory Forest Edition 10.0.1.
  4. Create new or import existing scheduled backup creation tasks.

Recovery Manager for Active Directory Forest Edition is fully compatible with FIPS-compliant algorithms: You can install the product on computers and use it to back up domain controllers that have FIPS-compliant algorithms enabled.

Important: Recovery Manager for Active Directory Forest Edition 10.0.1 does not support encrypted backups of domain controllers that have FIPS algorithms enabled and were created by Recovery Manager for Active Directory Forest Edition version 8.5.2 or earlier. After upgrading to version 10.0.1, back up all such domain controllers again.

Additional resources

Additional information is available from the following:

Globalization

Globalization

This section contains information about installing and operating this product in non-English configurations, such as those needed by customers outside of North America. This section does not replace the materials about supported platforms and configurations found elsewhere in the product documentation.

This release is Unicode-enabled and supports any character set. In this release, all product components should be configured to use the same or compatible character encodings and should be installed to use the same locale and regional options. This release is targeted to support operations in the following regions: North America, Western Europe and Latin America, Central and Eastern Europe, Far-East Asia, Japan.

Documents connexes