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Fetch and grid limit option does not work in Vertica (ODBC) connections.
Description
When working with Vertica, setting Value for "Numbers of rows to initially fetch in data tab" to 500 but does not seem to limit the queries in data tabs or browser grids causing TOAD try and pull back all data (instead of stopping at 500) and hang when attempting to browse large tables or result sets.
Cause
We do support fetch/rows limit options on any ODBC type connection (i.e.Vertica, Netezza, etc). The syntax for limit data is different for different platforms.
Résolution
WORKAROUND:
Do not access from Schema Browser or Viewer Table <table> | Data tab. To review data for a table, run a query manually in editor and limit the result set with a conditions.
STATUS:
Waiting for fix in a future version of Toad Data Point.
Identifiant du défaut
QAT-4966
Informations supplémentaires
This may apply to various versions of Toad Data Point and Toad Intelligence Central.
For connections not under ODBC, also verify that the "unlimited" option is not also checked. This will return all rows for a query, regardless of the value specified in the fetch setting. Also note, the option to "Apply to editor" needs to be enabled if this limit also need to be applied when manually running queries in the editor window.
Also note there are two of these settings. One is under Options | Database | Oracle, which will only apply to Oracle connections. The other is under Options | Database | General, which will apply to all other connections (except ODBC connections).
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Contenu recommandé
Produit(s) :
Toad Data Point
Toad Intelligence Central
Sujet(s) :
Troubleshooting
Historique de l’article :
Créé le : 3/30/2015 Dernière mise à jour le : 5/7/2023
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