Chat now with support
Chat con el soporte

Metalogix Email Migrator 4.7.1 - Help

Introduction Getting started Migration User Interface Configuration Troubleshooting & Tips

Explorer Windows and Views

The Metalogix Email Migrator's user interface uses an Explorer Control style window to navigate, view, and select the desired content for migration. The Explorer Control window is broken up into two separate tab options: Explorer View, and Browser view:

 

Explorer View - This is an Explorer tree view of the servers that are connected to Email Migrator. The tree view lets users easily navigate to a mailbox or a folder of their choosing, and run actions on these servers or folders straight from the selected node.

Browser View - The Browser view will display any selected node from the Explorer View in the format that it would appear in, if navigated to using a Web Browser, and is fully interactive. Any action that can be performed in archive system from a normal web browser can also be performed in the Browser View.

In the Explorer window there is also a Location bar. This bar will display the full location of the selected node (for that window). The Location bar can be copied to a clipboard for other use. This line will also work as a navigation link, and clicking on this link will open the selected location in a browser window, e.g. in case of an Exchange connection using the EWS connector clicking this link will navigate you to the respective folder or item in (Outlook Web Access) OWA.

Both tabs contain its own set of options for viewing content and data. This page will review which the available options are for each tab. The filtering and sorting options are only available on the root connection nodes.

 

 

Explorer View Tab

The Explorer view tab allows users to navigate through their various connections using a tree view method. This allows users to navigate to, and select a desired mailbox under a specific connection. As the cursor is hovered over the items in the Explorer view, checkboxes appear next to the items allowing multi-select.

There are a set of filtering options that are available to users in this tab, as well as a set of ordering options. This allows users to display, sort, and filter all of their connections as desired.

The Filtering options are broken up into three main parts: a text Filter value, Connections Filter, and Status Filter.

Note: Any connections that are not visible when filtering is applied are not actually removed from Email Migrator, they are only hidden from the current view.

Filter - This option consists of two parts, a text box field and a button to run the filter. Users can enter any desired text value in the filter text box (any text/number combination). After the value is entered users can either click the Enter key on the keyboard, or they can click the Filter button next to the filter text box to run the filter action. Only connections that contain the entered value will be displayed. Only a single text value filter can be used at a time.

For example, if users only want to view connections that contain "2010" in the URL, they can enter "2010" in the Filter text box, and click the Filter button to the right of the text value. The filter will then be applied to all connections in that Explorer View tab, and only connections that contain a "2010" value will be displayed.

To remove a text box filter, delete the filter value from the text box and re-run the filter action.

 

Connections Filter

Image(570)

This is the second of the three main filtering options, and consists of a drop down option that is next to the text box filtering option (above). This drop down menu allows users to filter out connections from the Explorer View tab. In Email Migrator there are all available connections in this drop down menu. By default, all of these options are selected, meaning that all connection types are visible in the Explorer View tab. A check-mark will be listed beside each option in the drop down menu that is currently included and being displayed in the Explorer View tab. If one of these options is selected from the drop down menu, and a check-mark is no longer next to the connection type, that connection type will not be displayed in the Explorer View tab. Multiple options in the drop down menu can be selected, or deselected at a time.

 

Status Filter Image(569)

This is the last of the three main filtering options. This drop down menu option is next to the Connections Filter option (above). When this drop down menu is opened, it will display a list of various connection status options. A breakdown of these status types is below.

o NotChecked – Email Migrator has not tried to validate the connection yet.

o Checking – Email Migrator is currently trying to validate the connection.

o Valid – Email Migrator has tried to validate the connection, and has been successful. A connection has been established.

o Invalid – Email Migrator has tried to validate the connection, and has been unsuccessful. A connection has not been established.

o Warning – Email Migrator has tried to validate the connection, and has been successful. A connection has been established, however, a warning message has been given.

By default all of the status types are selected in the drop down menu, so all status types will be visible in the Explorer View tab. A check-mark will be listed beside each option in the drop down menu that is currently included and being displayed in the Explorer View tab. If one of these options is selected from the drop down menu, and a check-mark is no longer next to the connection status, that status type will not be displayed in the Explorer View tab. Multiple options in the drop down menu can be selected, or deselected at a time.

Aside from the Filtering options there is also the ability to Sort the content. The Sorting option can be chosen from the Sort By drop down menu. All of the sort options are available in ascending order only. The available options are:

Default - This is the default sorting action and will list all of the added connections in the order they were added to the Email Migrator Explorer View tab.

Type - This sort type will list all of the visible connections by their Type. These are the same types that are listed in the Connections Filter drop down menu. Present connector nodes will be listed alphabetically.

Url - This sort type will list all of the visible connections in alphabetical order of the URL. This ignores the "http://" at the beginning of the URL and takes the remainder for ordering.

Users can combine the various filter options with the desired sort method to display only a desired set of connections.

 

Browser View Tab

The Browser View tab is available for any archive connector node that is selected in the Explorer View tab. When selected, this tab will display a fully functioning web browser view of the selected content. Users can use this Browser View to navigate or work with their content, the same way they would through a normal web browser window.

 

Image(607)

 

There are a few web browser buttons that are available in the Browser View tab for use when navigating the selected node through this view. The available options are:

Back - This button navigates the browser view back to the previous page.

Forward - This button navigates the browser view to the next page, if the user has already used the Back button.

Stop - This button will stop the loading of any page that is being navigated to.

Refresh - This button will refresh the current page.

 

 

Job List

The Job List view can be opened or closed from the View > Show Jobs List option in the main toolbar. Jobs in Email Migrator can be managed from the Job List. In the Job List section Jobs can be selected individually, or multiple jobs can be selected with multi-select. Below is a quick breakdown of some of the options:

 

Image(560)

 

File - This allows users to directly connect to a Job database, or even import Jobs from an XML file. When Refreshed, up-to-date details are displayed even for jobs run via PowerShell.

The refresh is applied to whichever job list Email Migrator is currently connected to, whether that is the Agent Database (for the Distributed Migration feature) or a standard job list.

Users can also quickly access one of the last jobs to have been selected from a quick list at the bottom of the File drop down option. When a Job List is selected the Job List area will populate with any jobs that exist in the Job List, and users can run other operations on individual or multiple Jobs.

Run Jobs Locally - Click it to run any selected Jobs (on the local machine) that exist in the Job List.

Run Jobs Remotely - Click to run any selected job on remote machines when using the Distributed Migration feature.

Migrate Failed Items - Should job complete with some failed items (indicated in the Log Summary column of the job list) it is possible to re-run it over the failed items only and try to migrate them again; this function is available for Archive-To-Archive jobs

Delete Jobs - This will Delete any Jobs that are selected in the current Job List.

Export Excel - This option allows user to export selected job data to excel tables and charts. It is also possible to select multiple jobs and then click this option. Excel report will be created for the given jobs. It contains transparent charts and tables on log items, operation counts, operation durations etc.

View Log - This option will allow users to select and view Log files for any selected Jobs. A Log Viewer dialog box will open, and here users can filter and view any log files. For more information on this, please see the section on Log Files.

Change Configuration - This option allows users to select a specific job in a Job List, and change the configuration of that job. The options for the configuration change will be different depending on the type of job that was created.

Generate PowerShell Script - This option allows generating PowerShell scripts for any job in the job list, either completed, aborted or just saved. Script as an extensively customizable resource offers wide configuration and application options. Administrator can modify the script and tailor it to specific requirements, e.g. modify or filter users, create several jobs and then run them as a batch task. This feature can be especially useful for bigger migrations including 20,000 and more users. Such extensive tasks may be fragmented to several steps where first only users are migrated and only then the item migration follows. For more detailed information see the Generating PowerShell scripts section.

Schedule task - This option allows user to create and add tasks to Windows Task Scheduler based on the job selected in the list view. Check the already scheduled tasks by clicking the Schedule Task / View Task Scheduler option. For more information on Windows Task Scheduler, see this link.

Right-clicking on any of the Jobs in the Job List will also open some options for users. Most of these options will remain the same except for the new ones:

Copy selected job to clipboard - This option allows users to copy the text from any selected job file to the clipboard, which can then be pasted into a word file or a spreadsheet. When a job list is selected, only the total or end result of the job will be given. Individual job file items must be selected and copied separately. For more information on this option, please see the Log File section.

Export selected job to xml - This option will open a log file for a selected Job as an XML file. The XML file will automatically open in whatever program is set as the default application for XML files, where it can be saved to any desired location.

View aggregate log for selected jobs - This option is only available if multiple jobs are select in the Job List. This option will open all of the logs for all of the selected Jobs in a single Log Viewer. This allows logs for multiple jobs to be reviewed in a single window.

Create support zip file - This option will create zip file for the given job containing all information necessary to troubleshoot any possible issues

Image(6)(1)

ATTENTION:

Please review the contents of the zip file before sending it to support. While this feature attempts to only collect non-sensitive data, no guarantees can be made - it is up to you to ensure that any files in the zip folder are stripped of any confidential data. Regardless, our company assures that the contents of the zip file will only be used for troubleshooting the

associated support ticket .)

 

Please see the section on Log Files for more information on this topic.

 

 

Log Files

Metalogix Email Migrator has a live view of its logging. When starting an action, users have the ability to click Details>> in the progress dialog box, and they will be able to view the logs for the action, even while it is still running.

 

 

Image(6)(1)

ATTENTION:

All logging in Email Migrator is done through jobs. If a job list is deleted from the Job List section, all logging for those actions will also be deleted. There is no backup for the job lists, unless the job is manually saved to another location by the user. Once a job list is deleted, all logging for the actions within that job list are gone. Email Migrator will automatically hold any job lists created through any copy actions, in the Job Lists section, and these job lists can only be deleted through the appropriate Delete commands. The job lists can also be manually selected and saved through the Job list section.

 

The second type of job file, is a job list. A job list is a collection of job items, and can be selected in the Job List section. A Job list is created for each migration action that is made. Any "Copy" action/job that is in the Job List section can be used as the base of an incremental copy job. Job items can be viewed in the Log Viewer, by opening a job list. There are three basic ways to open a job list to access the Log Viewer:

Double-click on a job in the list.

Select a job list, and click the View Log button in the Job List section of the toolbar.

Select a job, right-click, and select View log for selected job.

 

Image(487)

 

From the Log Viewer users can select and view any job items that exist within that job list. Filtering is available through Show Log Items button on the left above the list view. In the drop-down options select the items to be displayed by their status - Failure, Different, Missing On Source, Missing On Target, Skipped, Warning, Completed.

Note: Some actions in the Email Migrator have the ability to run Verbose Logging when they are running. This option will increase the size of the log file.

 

 

Importing Job Files from XML

This option allows users to import Jobs from an XML file. This option is mainly used for importing Job files from other instances Email Migrator so the logs can be viewed. Or it can be used for modifying a previously exported Job, and re-importing it back after some manual changes have been made.

Note: If the XML file that is being imported contains the same ID value as an already existing Job, then the import will fail.

To import an XML file to the Job List, users can do the following:

1. Have an XML file that is already set to be imported that uses a different ID value from any existing Jobs (this should only be an issue if the XML file was previously exported from Email Migrator).

2. In the Job List, select File > Import Jobs From Xml.

3. This will open a file browser window that can be used to navigate to, and select, the XML file for import. Select the desired file and click Open.

4. Email Migrator will attempt to import the Job file. If successful, the job will be listed in the Job List section, and can be viewed the same as any other Job. If unsuccessful, an error message will be given.

 

Exporting Job Files as XML

Logs in the Job List also can be exported/viewed as XML. To do this:

1. Select the desired job in the Job List section.

 

Image(560)

 

2. Right-click, and select Export selected job to xml. This will open the log file for the job as an XML file. The XML file will automatically open in whatever program is set as the default application for XML files, where it can be saved to any desired location.

 

Exporting Failed Job Items as MSG

Logs in the Job List may contain some failed items that were not migrated by the given job. It may be caused by many different issues. Email Migrator allows you to export such failed items in MSG format to location you choose, e. g.  for troubleshooting purposes. To do this:

1. Open the job log file with failed items.

2. Right-click the failed item and from the context menu choose Export item. (Note: Available after job finish. Multiselection is also possible.)

3. Define the target location and export the file (in MSG format).

 

log

Note: This feature is not supported for the following source connectors:

- Barracuda Message Archiver connection

- Exchange Fast Transfer connection

- Email Mailbox connection

 

Log Item Details

The Log Item Details window can be reached by a few different methods. These methods include: double-clicking on a job item in the Log Viewer, double-clicking an item in the Details section of an action, or as a right-click option in the Details of an action. Additionally logging information can be viewed about each job item in the Log Item Details dialog.

 

Image(483)

 

Time Started - Time when the specific action was started.

Time Finished - Time when the specific action was finished.

Operation - Lists the type of the last operation performed on the item.

Status - Lists the status type of the item. This could be: completed, failed or warning.

Item Name - For items this will display the Item ID.

Data Migrated - Lists the number of mailboxes that were copied in the action.

Source - Lists the Source URL for the item.

Target - Lists the Target URL for the item.

Information - Provides an information message about the item. This section will provide a description for any different and/or missing attributes/metadata for an item.

Content Comparer tab - This option is used more if Verbose Logging has been checked. The window will display any differences for the Source and Target content (from a compare action), in the windows provided. Users have the option of viewing this information from either a Grid view, which displays a metadata property grid for the item, or as a Text view, that displays a XML text format of the item.

Details tab - Will provide a list, with details, of any errors that were encountered with the item when an action was performed.

Copy - This will copy all of the item information and details (including the Details tab) into the systems clipboard, when it can then be pasted to another location. When pasted the information will look similar to that of the actual Log Item Details dialog. This can be used for easy copy/pasting of an items migration log details.

Prev/Next buttons - Switches the Log Item Details to view a previous or next item on the list (if applicable).

Close - This will close the Log Item Details dialog window.

 

Copying the Logging for Jobs

It is possible to copy the logging for job lists and job items to other applications. This can be beneficial if users are trying to keep track of copy or incremental information. Logging information can be copied from: selected items in a job list, the end result of a job list, or all items within a job list. Copying of logs for jobs can be done as often as necessary, as long as users are still able to view the job. The log information from the jobs will be copied as text, to the clipboard, and can then be pasted within any other application that allows text pasting. For example, if a copy action was made, the logging can be copied into a Word file, or into an excel spreadsheet, then saved. Then the next time a similar action is made, its logging can be added to the previous file.

To copy the logging for a job list, follow the below steps:

1. Select a job from the Job List.

2. Right-click, and select Copy selected job to clipboard (alternately Ctrl+C can be used).

3. Open the desired target program (for example: Microsoft Word, Microsoft Excel, Notepad, etc.). Now paste the content into the application (Ctrl+V, or the paste command in the application itself). The logging for the Job list should now be pasted into the other application.

It is important to note two things here. The first is that when copying the logging for a job list, only the end results of the total action will be copied. The logging for each action within the list must be copied separately. The second thing to note is that once the logging has been pasted, users are able to edit and manipulate the information the same way they can for any other text information.

To copy the logging for job items, follow the below steps:

1. Select the desired job list or job item(s) that the logging is to be copied from, and open the job list to access the Log Viewer.

2. Select any job items that are to be copied. Single or multiple items can be selected in the Log Viewer. In order to copy the logging for the entire job, all job items in the Log Viewer must be selected.

3. When all of the desired items are selected, right-click on one of them, select Copy Log Items to Clipboard, and select to either copy them with, or without details. The Details are a set of extra columns that are added to the logging. These columns are typically: Details, SourceContent, and TargetContent. These columns do not always contain extra information. The default copy option (Ctrl+C) is to copy the logging without the Details.

 

Image(484)

 

Context menu

Context menu works for every server node or mailbox in the Explorer view. Available menu options differ depending on the selected item - server or mailbox.

 

Image(18)

Image(504)

 

Server node context menu:

Paste Mailboxes - this option starts the migration process with the selected node being the target; It is available only on Archive Manager node when "Copy Archive Server/Copy Archive Mailbox" option has been selected on any node/mailbox before

Copy Archive/Email Server - selected node with all its mailboxes is copied for the migration process

Disconnect - the connection to the selected server is canceled, i. e. the node disappears from the list

Edit Connection - opens the Connect to... dialog where you can edit connection parameters for the given connection (also "folder" connection)

Refresh - refreshes the current view

Export Mailboxes to CSV File - exports list of mailboxes for the given node to CSV file to your selected path

Show/Hide email address - this option displays user email address next to the default display name under the main node; this helps distinguish users with equal display names but different email addresses

Properties - opens read-only Node Properties window (see below) with node properties; It could provide detailed useful information for technical support team

 

 

Image(20)

Properties of Archive Manager node

 

 

Group node context menu:

(Grouping based on users (logging) is available in Quest connector if groups are present in the given Quest installation and in Symantec connector with more than 500 users if Symantec property "Office" is set)

Copy Archive Mailbox Group - selected group with all its mailboxes is copied for migration process

Load Mailbox Info - select this option to display the number of mailbox items and their size for each mailbox in the group and a summary for the group itself; numbers appear in the brackets next to the mailbox name

 

 

 

PST Search node context menu:

(Available for connections in Email Migrator created via Search PST Files feature)

·Search PST Files - (available also for individual computer nodes) click this option to look up all PST files in the given domain/computer. The number of existing PST files appears in the brackets next to the given computer. Unfold the computer node to see and manage these PST files.

·Assign PST Owners - (available also for individual computer nodes) click this option to look up all PST files in the given domain/computer. The number of existing PST files appears in the brackets next to the given computer. Unfold the computer node to see and manage these PST files.

·Find Computers - click this option to list all computers from the domain

·Add Computers - click this option to add just specific computer existing in the domain

 

 

 

Mailbox (single PST) node context menu:

Image(9)

NOTE:

Multiselect for mailboxes is possible - see the screenshot below.

 

Copy (Archive) Mailbox(es) - selected mailbox(es) are copied for the migration process

Remove shortcuts - (for Exchange connections) shortcuts of different archive systems can be removed from the mailbox

Compare Mailbox/Compare with Mailbox - visible only in advanced mode (Settings/Enable Advanced Mode) - (applicable for Exchange connections) verifying successful migration; the function checks if the subject and body of the item are the same on source and target; To use the feature:

1. Right-click the source mailbox and from the context menu select Compare Mailbox option

2. Right-click the target mailbox and from the context menu select Compare with Mailbox option

3. The progress dialog appears and you can check the log

This process can run alongside the migration when Verify items migration option is checked. However, it slows down the migration itself.

 

Image(505)

 

Refresh - refreshes the current view

Properties - opens read-only Properties window with mailbox properties; It could provide detailed useful information for technical support team

Load Mailbox(es) Info -  if the number of mailbox items is not displayed, select this option and the number of mailbox items and their size appear in the brackets next to the mailbox name;

With Advanced mode enabled (on the Settings tab of the main toolbar), it is possible to set filters for mailbox items. In this way administrator can display number of specific mailbox item satisfying defined criteria (size, received date, item classes, messages in Primary Mailbox, messages in Archive Mailbox). Just click the Load Mailbox(es) Info and define your criteria in the pop-up dialog (see the screen-shot below). For instance, find out how many items are bigger than 5 MB and older then a month.

Image(9)

NOTE:

Filtering does not apply for Gmail connectors.

 

Image(606)

 

Documentos relacionados