Chatee ahora con Soporte
Chat con el soporte

Binary Tree Migrator for Notes 20.11 - Requirements

Appendix B: Office 365 Modern Authentication

This section outlines the additional requirements for the use of Microsoft Office 365 / Microsoft 365 Modern Authentication for the Migration Controller and Migration Workers. These are only needed if Modern Authentication is to be used for PowerShell and Outlook connections to the target system.

The target tenant does require Modern Authentication to be enabled to use this migration processing.

 


Microsoft do not currently enforce Modern Authentication for Office 365 but do have a change to this tentatively scheduled for the second half of 2021. Please review Microsoft online documentation for further details.

Migration Controller Requirements

  • PowerShell 5.1 (part of Windows Management Framework 5.1)

  • .Net 4.7.1

  • WinRM basic authentication allowed

  • TLS 1.2 enabled for .Net Framework

  • ExchangeOnline PowerShell Module

 

Migration Worker Requirements

  • Outlook 2016 or Outlook 2019 (Outlook 2013 is not supported for migrations with Modern Authentication)

  • Windows Server 2012 R2, Windows Server 2016 or Windows Server 2019 (Windows client operating systems are not supported for Modern Authentication)

  • Outlook profile configured for the worker migration account and named Migrate

 


Multi-Factor Authentication is not supported.

 

Migration Controller Requirements

This section outlines the additional requirements for the use of Microsoft Office 365 / Microsoft 365 Modern Authentication for the Migration Controller and Migration Workers. These are only needed if Modern Authentication is to be used for PowerShell and Outlook connections to the target system.

The target tenant does require Modern Authentication to be enabled to use this migration processing.

 


Microsoft do not currently enforce Modern Authentication for Office 365 but do have a change to this tentatively scheduled for the second half of 2021. Please review Microsoft online documentation for further details.

  • PowerShell 5.1 (part of Windows Management Framework 5.1)

  • .Net 4.7.1

  • WinRM basic authentication allowed

  • TLS 1.2 enabled for .Net Framework

  • ExchangeOnline PowerShell Module

 

Migration Worker Requirements

  • Outlook 2016 or Outlook 2019 (Outlook 2013 is not supported for migrations with Modern Authentication)

  • Windows Server 2012 R2, Windows Server 2016 or Windows Server 2019 (Windows client operating systems are not supported for Modern Authentication)

  • Outlook profile configured for the worker migration account and named Migrate

 


Multi-Factor Authentication is not supported.

 

Migration Worker Requirements

This section outlines the additional requirements for the use of Microsoft Office 365 / Microsoft 365 Modern Authentication for the Migration Controller and Migration Workers. These are only needed if Modern Authentication is to be used for PowerShell and Outlook connections to the target system.

The target tenant does require Modern Authentication to be enabled to use this migration processing.

 


Microsoft do not currently enforce Modern Authentication for Office 365 but do have a change to this tentatively scheduled for the second half of 2021. Please review Microsoft online documentation for further details.

Migration Controller Requirements

  • PowerShell 5.1 (part of Windows Management Framework 5.1)

  • .Net 4.7.1

  • WinRM basic authentication allowed

  • TLS 1.2 enabled for .Net Framework

  • ExchangeOnline PowerShell Module

 

  • Outlook 2016 or Outlook 2019 (Outlook 2013 is not supported for migrations with Modern Authentication)

  • Windows Server 2012 R2, Windows Server 2016 or Windows Server 2019 (Windows client operating systems are not supported for Modern Authentication)

  • Outlook profile configured for the worker migration account and named Migrate

 


Multi-Factor Authentication is not supported.

 

Documentos relacionados

The document was helpful.

Seleccionar calificación

I easily found the information I needed.

Seleccionar calificación