The process is unable to read our other subdomains:
In the Discover Logs you will see the following error:
Cause 1
The domains may be configured to only accept the legacy NETBIOS user logon format (DOMAIN\User) rather than UserPrincipalName format (user@domain.local).
Cause 2
NTLM authentication is disabled.
Resolution 1
Navigate to the ODM Directory Sync Agent server.
Open elevated regedit session.
Navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Binary Tree\P365Agent\UserName key
or
HKEY_LOCAL_MACHINE\SOFTWARE\Quest\On Demand Migration For Active Directory\ODMAD_DS\UserName
Double click on UserName key:
Change the format from UPN to "Domain\ServiceAccount" format
Navigate to Services
Restart the On Demand Directory Sync Agent Service
Navigate to the On Demand Migration UI dashboard and re-run the Discover process. You should now note the error message is no longer present.
Additionally the all domains (to include sub-domains) are read as expected.
Resolution 2
Enable NTLM authentication. If NTLM was disabled via Group Policy, it will need to be allowed in Group Policy. Then it will likely need to be separately enabled using the Local Security Policy on the Domain Controllers.
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