An error occurred while attempting to load the archive when attempting an AD object recovery.
説明
When attempting an AD object recovery the following error is received :
An error occurred while attempting to load the archive. One or more errors occurred.
Access to the path 'C:\Program Files\Quest\Active Administrator\ADBackupCache\0.dat.0' is denied. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.File.InternalDelete(String path, Boolean checkHost) at Quest.AA.Providers.Recovery.RecoveryProvider.SetADBackupCacheDirectory() at Quest.AA.Providers.Recovery.RecoveryProvider.ExtractBackupFiles(ADArchive archive) at Quest.AA.Providers.Recovery.RecoveryProvider.SetArchiveInfo(ADArchive archive) at Quest.AA.ViewModels.Recovery.Restore.RestoreLoadingArchivesScreenViewModel.<InitializeCore>b__1_0() at System.Threading.Tasks.Task.Execute()
原因
Account logged on the Active Administrator server does not have Full control on C:\Program Files\Quest\Active Administrator\ADBackupCache folder.
対策
Grant full control to the user account under C:\Program Files\Quest\Active Administrator\ADBackupCache folder security permissions. Then, log off and log back into the server and open the console to try the AD object restore from backup. Also verify that AA console is opened by the Foundation service user account.