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Overview 

 

Overview 

Evolve 360 is a full-featured, cloud-based set of enterprise architecture tools using industry frameworks 

build to create a structure for your business by using your business data. 

Evolve 360 comes with all that is needed for an editor called Application Editor. It helps create the new 

application for your product, choices from the wide variety of pre-loaded views. All you need to configure 

with the desired data to display the results. It comes with the in-built diagramming tool called Diagrammer 

to create and edit diagrams online. 
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To get started 

 

To get started 

Log in to the application with the provided credentials. 

Steps to create an application: 

1. To create the new application, click on Create Application. 

 

 
If you do not have any previous licenses or its your first time, it takes you to the above shown picture to 

create a new application. 

 

2. Enter Name > Description (if required) 

Select Community Access (if available) > select Icon and Color. 

Click on Create. 
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3. An Application Editor will be opened. To configure home view, click on Home View (Not Configured). 

 
Configuring this, will be the landing page for your application. 

4. Click on Configure Home View and then choose the kind of layout or view you wish to configure from 

the list. 
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To get started 

 

  

 To learn more about configuring layout and each type of view, please refer the respective view sections. 
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Metamodel 

Object Types 

How Do I Add A New Object Type? 

1. Click on the profile, go to Object Types 

 

2. Click the + icon in the list view on the left-hand side of the screen, this will create a blank new 

Object Type. 

 

3. Enter Name and Description. Add an Icon and Color you wish to assign to the new object type. 
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To add Attributes and their definition, click on + icon on the right below corner of the screen. 

 

4. To add new Attributes: 

a. Select type of Attribute from the list. 

b. For each new Attribute you can provide a Name, Description, Default Value and choose if 

they are Mandatory. 

Some Attributes such as List or Array require additional information which are unique to that 

Attribute type e.g., Key 

c. Click on Save. 
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How Do I Add an Attribute to an Existing Object Type? 

Available Attribute Types 

1. Boolean - Simple true/false attribute 

2. Integer - A whole number not a fraction 

3. Real - Whole number/fraction/positive or negative 

4. String - Text with a limit of 255 characters 

5. URL - Set a URL for use as a clickable hyperlink or an Item Action 

6. Date Time - Set a single point in time 

7. Date Time Range - Define a range of time with a start and end date 

8. List (Single) - Create a single choice list  

9. List (Multiple) - Create a multiple-choice list 

10. Array (Single) - Set a single choice key & value array 

11. Array (Multiple) - Set a multiple-choice key & value array 

12. Scorecard - Allows users to use a predefined ‘scorecard’ to perform equations on numeric 

attributes 

13. Relationship List - Create a pick-list from a defined relationship and object type 

14. Numeric Rollup – Roll up numeric values through relationships 

15. Date Time Rollup – Roll up date-times through relationships 

16. Date Time Range Rollup – Roll up date-time range through relationships 

17. Long String - Text with a limit of 16,383 characters 

18. Image - Allow users to attach an image to an object instance 

 

Configuring an Attribute 

1. Click on the profile, go to Object Types. 

2. Search for a specific Object Type to add an Attribute or you can manually scroll through the list. 

3. Click on the Object Type in the list to bring up its details. 

4. Click on the blue + button in the bottom right of the details view. 
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5. This will bring up a blank Attribute. Select your Attribute Type 

6. Enter new Attribute a Name & Description. 

You can also set a Default Value for new Instances of the Object Type 

And finally, choose if your new Attribute is Mandatory by checking the box 

a. Some Attributes such as List or Array require additional information which are unique 

to that Attributes Type e.g. Key 

7. Click Save in the bottom right of the screen to finish adding the new attribute. 

 
 

 A default view is required to see Object Types. To create the default view, (see topic link) 
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Relationships 

How Do I Create A New Relationship? 

To add the Relationships, go to Object Types and select from the list you wish to add. 

Click on the tab Relationships. 

 

 

 
By default, every Object Type will have its wildcard Relationships that exists in the model and populated 

automatically. 

To add a new Relationship, click on + icon at the right bottom of the screen. This will show the four types of 

Relationships available. 

1. Create Relationship Type 

2. Create Relationship Type with Object 

3. Create Parent Relationship Type 

4. Create Child Relationship Type 
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Create Relationship Type 

To create a simple Relationship between the objects, 

1. Go to Create Relationship Type. 

2. Select Source and Target, enter Source Name and Target Name. 

 
 

3. Click on Save. 

Create Relationship Type with Object 

Create Relationship Type with Object works similarly as the first relationship type, but if you want an object 

to represent the relationship, then select Create Relationship Type with Object. 

This will create an Object Type with the Relationship. 
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1. Go to Create Relationship Type with Object. 

2. Select Source and Target, enter Source Name and Target Name. 

Enter Object Name to display. 

 
3. Click on Save. 

Create Parent Relationship Type 

Create Parent Relationship Type is used to relate the parent to the Child Object Instances. 

To create parent-child relationship, 

1. Go to Create Parent Relationship Type 

2. Select Parent and Child, enter Parent Name and Child Name. 

 
3. Click on Save. 

 

 Enter Parent and Child names that explains its relationship. 
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Create Child Relationship Type 

Create Child Relationship Type is used to relate the child to the parent Object Instances. 

To create child-parent relationship, 

1. Go to Create Child Relationship Type 

2. Select Parent and Child, enter Parent Name and Child Name. 

 
3. Click on Save. 
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Filters 

How Do I Create A New Filter ? 

1. Click on the profile, go to Filters 

 

1. Click the + icon in the list view on the left-hand side of the screen, this will create a blank New 

Filter. 

 

2. Enter Name and Description. Add Parameters if you wish to. 

3. Select the Object Type you wish to filter by. 

If you wish to filter only by Object Type with no further criteria, press the Trash icon on the 

additional criteria and click save. 
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This will create a filter which display all Business Terms as shown in the below figure. 

 

4. To add the further criteria, press the Object Type Criteria ‘+’ icon next to the Object Type. 

i. First additional operator will be AND, every additional operator afterwards will be an OR. 

ii. Select the object type criteria you wish to filter by. 

There are 4 main criteria categories 

▪ ‘Is Object’ – You can select individual Objects of that Object Type 

▪ ‘Use Filter’ – Will only show Objects of your selected Object Type that appear as results 

of the selected filter 

▪ ‘Generic Properties’ – Properties that are of all Object Types 

▪ ‘Attribute Properties’ – Attributes of that specific Object Type 

iii. Select the Property. Depending on the Property you select, it presents with different 

operators. 

▪ ‘Is Object’ – Equals, Does not equal 

▪ ‘Use Filter’ – Is in filter, Is not in filter 

▪ ‘Generic Properties’ – Equals, Does not equal, Starts with, Does not start with, 

Contains, Does not contain, Ends with, Does not end with 

▪ ‘Attribute Properties’ – Equals, Does not equal, Has value, Does not have value 

iv. Enter the Value. Depending on the criteria you selected, you need to either enter a Value or 

select related from the pickup list.  

v. If you wish to add another step, click on ‘+’icon next to your first operator. 

vi. Follow the steps i to iv to add details for an additional criteria branch. 
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5. If you wish to enter further Object Type Criteria to filter, click on Add New Object Type Criteria 

shown in blue color below the operations.  

Repeat Steps from 4 to add new filter. 

6. Once Object Type Filters are added, click on Save. 
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Scorecards 

Scorecards are templated formula, which can be applied to the Object Types. It helps you manage and 

evaluate metrics that can be applied to objects. With many objects, creating an automated score is the best 

way to calculate value. 

How Do I Create a New Scorecard? 

1. Click on the profile, go to Scorecards. 

 

2. Click the + icon in the list view on the left-hand side of the screen, this will create a blank new 

Scorecard. 

 

3. Enter Name and Description. Click on + icon at the bottom of the screen to Add Values to the 

formula. 



    

 

 

erwin Evolve 360- User Help Guide 
17 

Metamodel 

 

 

4. You need to click multiple times to add required values. Click on the expansion button against each 

value and then enter Name and Description for every value added. 

 

5. Edit the Formula, if needed. To finish creating a Scorecard, click on Save from the right bottom of 

the screen. 
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How Do I Add Scorecard to Object Type? 

1. Go to profile, click on Object Types. 

Select the desired Object Type from the list you wish to add Scorecard. 

 
 

2. Click + icon from the right bottom of the screen. This will open the blank attribute defining options. 

i. Select Type as Scorecard from the list. Enter the Name and Description (optional). 

ii. Click on Scorecard, Select the Scorecard from the list you wish to apply. 
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3. Select the Attribute Definition for each Attribute. 

 
4. To finish adding Scorecard, click on Save. 
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Workspaces 

Workspaces are supported by the Client areas. Workspaces can be set up by an administrator. 

How Do I Add A New Workspace? 

1. Click on the profile, go to Workspaces 

 

2. Click the + icon on the left-hand side of the screen, this will create a blank New Workspace. 

 

3. Enter Name, Description, and an Icon to your new Workspace. 

You can set the Workspace as Default and restrict a Workspace to a Community. 
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4. Click Save. 
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Layouts 

Layout views in the application editor are used to plan or design the arrangement of the information. 

Application Layout can be customized using multiple types of layouts. 

Layouts come in six different types to create a cohesive look and structure for the application. 

1. Menu 

2. Tabs Layout 

3. Column Layout 

4. Row Layout 

5. Stream Layout 

6. Accordion Layout 

7. Carousel Layout 
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Menu View 

Menu view in the Layout is used to create a structure with a separate set of information on the same page.  

To create a Menu View, 

1. Click on All Views in the application editor and then click on  icon placed at the bottom of the 

list of views, then select Menu.  

 
 

2. Click on Add Menu Item icon from the toolbar or click on Configuration to add the menu items. 

 
3. To Enable Fixed Menu, click on the icon shown in the picture below. 
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To customize the Menu Width, click on Configure Fixed Menu Width shown above. 

Enter the value and then click on Apply. 

 

 The menu width should be greater than or equal to 200px. 

 

4. Click on Add Content and select the view type you wish to configure. 

You can add any other Layout, Collection, Charts, or Item Views under each menu as per your use 

case. 

For instance, a List View is configured in the view shown in the picture below. 
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 Go to respective view type to see how to configure. 

 

5. To configure the displaying title property, click on Title Property under Configuration 

• To add Icon and Color for the Menu, click on menu title and then select the menu item from 

the right-side configuration panel. 

• Select Icon and Color, and then click on Apply Changes. 

 

 Setting the Limit is available specifically for selected views. 

6. Multiple Menus will be displayed as shown in the picture below: 
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 Each Menu Item must be configured individually to see the result. 

 

How to work with Menu Groups? 

A multiple individual Menu Items can be assigned and grouped together under a Menu Group. 

To create a Menu Group and assign items, 

1. Go to Configuration on toolbar, then click on Menu Groups from the left-hand side. 

 
2. Click on +Add Menu Group > select the created group to edit. 

Enter Name > Select Parent Group (Optional) > Select Icon and Color > Apply Changes. 

 
 

 Selecting a Parent Group is adding a Menu Group inside another Menu Group. 

 

3. To assign the Items to the Group, 

Go to Menu Items > click on +Add Menu Item > Enter Name > Select the Menu Group > Select 

Icon and Color > Apply Changes. 
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4. Multiple Menu Items under a Menu Group will look as shown in the picture below. 
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Tabs 

Tabs View helps to organize the content in a separate section on a page. 

To create Tabs, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views 

and then select Tab Layout 

 
2. Click on Add Content to feed the view in each Tab. 

 
• To edit the Tabs, click on Configuration 

• Enter Display Name for the Layout. 

• Click on Tabs, which you wish to edit. 

• Enter the Tab Name and click on Apply Changes. 
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3. To configure the view tab, select the tab and then click on Configuration on the toolbar or right-click 

on the view. 

You can add any other Layout, Collection, Charts, or Item Views under each tab as per your use 

case. 

For instance, a List View is configured in the view shown in the picture below. 

 
4. To name the Tab, click on the main title. A list of tabs displays under Configuration on the right side of 

the screen. 
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Column Layout 

Column Layout helps create a modern dashboard with customizable columns size and positions in the editor. 

To create a Column Layout, 

1. Click All Views in the editor, then click on  icon placed at the bottom of the list of views. 

Select Column Layout from the list. 

 
2. A layout with two columns by default will be opened in the editor, as shown in the picture below. 

 
 

 

To add more columns, click on Add Column icon  from the toolbar. Or click on Edit, select 

 from the list 
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 The size of each Column can be adjusted by dragging the lines between the Columns. 

 

3. After adding content in the columns, select the Column and click Configuration on the toolbar or right-

click on the view. You can add any Collection, Charts, Item views as per your use case. 

For instance, a Table View and a List View added in the columns. You must configure each column 

individually. 
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Row Layout 

Row Layout helps create a modern dashboard with customizable rows size and position in the editor. 

To create a Row Layout, 

1. Click All Views in the editor, then click on  icon placed at the bottom of the list of views. 

2. Select Row Layout from the list. 

 
3. Click on Add Content > Add New View > Select the view type you wish to add. 

 
4. After adding content in the Rows, select the Row and click Configuration on the toolbar or right-click 

on the view. You can add any Collection, Charts, Item views as per your use case. 

For instance, a List View is added in the first row as shown in the picture below. You must configure 

each row individually. 
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 The size of each Row can be adjusted by dragging the lines between the Rows. 

Each Row must be configured similarly explained above. 
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Stream Layout 

Stream Layout is used to create the mixed content in the rows which can be scrolled. 

To create a Stream Layout, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Stream Layout from the list. 

 
3. A layout with two rows by default will be opened in the editor as shown in the picture below. 

Click the icon  to add Stream Items. 

 
4. Click on Add Content > Add New View > Select the view type you wish to add. Repeat the same 

step for other items too. 

5. After adding content in the layout, select the Stream and click Configuration on the toolbar or right-

click on the view. You can add any Collection, Charts, Item views as per your use case. 

For instance, a Table and List View is configured as shown in the picture below. You must configure 

each stream individually. 



    

 

 

erwin Evolve 360- User Help Guide 
35 

Layouts 
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Accordion Layout 

Accordion Layout helps to categorize a form or to create a flow to the information. 

Each accordion is used to toggle between hiding and showing the content. 

To create Accordion Layout, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Accordion Layout from the list. 

 
3. A default layout will be opened in the editor as shown in the picture below. 

Click the icon  to add Accordion Items. 

 
4. Click on Add Content > Add New View > Select the view type you wish to add. Repeat the same 

step for other items too. 

5. After adding content in the layout, select the Accordion and click Configuration on the toolbar or right-

click on the view. You can add any Collection, Charts, Item views as per your use case. 

For instance, a Table and List View is configured as shown in the picture below.  

You must configure each accordion individually. 
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6. To edit the Accordion titles,  

• Select the Layout title, and then click on Configuration. 

• Click on Accordion you wish to edit. 

• Enter Name and click on Apply Changes. 

 

 

Repeat Step -6 to edit all the accordions you add in the layout. 
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Carousel Layout 

Carousel Layout helps to create a cohesive look and structure for your application 

Carousel can be used to cycle through multiple pieces of content in single space. 

To create Carousel Layout, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Carousel Layout from the list. 

 
3. An unconfigured Carousel Layout will be opened in the editor as shown in the picture below. 

Click the icon  to add Carousel Items. 

 
4. Click on Add Content > Add New View > Select the view type you wish to add. Repeat the same 

step for other items too. 
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5. After adding content in the layout, select the Carousel and click Configuration on the toolbar or right-

click on the view. You can add any Collection, Charts, Item views as per your use case. 

You must configure each carousel item individually. 

 

6. To enable cycling interval for carousel items, click on   the toolbar or go to Configure and then 

select Enable Cycling. 

 

To set the Cycle Duration, click on the  clock symbol on the toolbar. 
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• Enter Duration in seconds 

• Click on Apply. 

 

 

 

 
Items in the Carousel Layouts can be any view type. To see the configuration of the selected item, visit that 

individual view type. 
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Collections 

Collection Views are data-driven views that allow you to see, navigate and interact with the model.  

Collection views are: 

1. Table  

2. Kanban 

3. List 

4. Accordion Collection 

5. Carousel Collection 

6. Tab Collection 

7. Card Collection 

8. Diagram View 

9. Network View 

10. Tree View 

11. Roadmap 

12. Calendar 

Among these, four views are considered as Special Views, i.e., Accordion Collection, Carousel Collection, 

Tab Collection and Card Collection.  
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Table 

Table is used to show the data at once in the large cross-section with vertical scrolling. 

To create Table View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Table from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Apply the Properties, Thumbnail Property and Tooltip Property according to the view. 

• Click Preview to see the result. 

 

 
4. An example of a Table View displaying with two properties Name and Definition is shown below. 
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Kanban 

Kanban view helps to create and interact with data grouped by an attribute. 

To create Kanban, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Kanban from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit of items to display. 

• Apply the Grouping Property, Properties of elements, and the available Properties as 

required. 

• Click Preview to see the result. 
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4. By default, a Property is set with Name. To add the other one, click on Add Property from the right-

side pane. 

Select Element Type > Select Property. 

Enable checkbox if you wish to have the property editable. 

Click on Apply Changes. 

 
5. The preview of configured Kanban View is shown in the picture below. 
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List 

List view help to navigate to the data which is looking for. It displays the objects within the model and can be 

customized. 

To create List View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select List from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Apply the Title Properties, Thumbnail Property and Tooltip Property as required. 

• Click Preview to see the result. 
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4. To add the Properties, click on Configure on the toolbar or right-click on the view being in the Design 

Mode. 

 
Click on + Add Property 

By default, a property is set with Name. To edit click on the property or to add the other one, click on 

+ Add Property from the right-side pane. 

Select Element Type > Select Property. 

Enable checkboxes if you wish. 

Click on Apply Changes. 

 
5. The preview of configured List View is shown in the picture below. 
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Diagram View 

Diagrams are two types, Manual and Auto diagrams. 

Manual Diagrams are integrated with Diagrammer, where you can create associations to the model and 

edit the diagrams manually.  

Auto Diagrams uses the same diagram types, but the diagrams are automatically drawn based on the data. 

They are dynamic, reads the data and generates the diagram through it. 

How to configure Manual Diagrams 

Manual Diagrams works as Object Type View, which requires a context from the source. 

An example to configure Manual Diagram,  

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. For instance, choose a Column Layout with a List in the Column 1. 

Select Data Source as Diagram. 

 
In column 2, select Object Type View 
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3. To pass the context from the source,  

• Click on three dots against the Object Type View from the left side then select Context 

Configuration. Or go to the columns list and then click on column 2. 

• Select Context Source > Internal > Apply. 

 
4. The Diagrams from the source will appear as shown in the picture below.  

You can edit the diagrams to create association in the model. To edit, click on icon  from the 

top right corner. 
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An editor called Diagrammer will be opened in the same space as shown in the picture below. 

 

 To know how to edit diagrams, see Diagramming 

5. To create a new diagram to the list. 

• Go to Configure on toolbar, then select Actions. 

 
• Click on +Add Action from the right-hand side. To edit, click on New Action created or 

click on three dots against it. 
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• Enter Label > set Position > select Behavior of the action. 

Choose Diagram Type and its Behavior 

Select Icon and Color to the new action 

Click on Apply Changes 

 

 Select Diagram Type is mandatory, such that you are defining a model by following that set of defined rules.  

 

 Make sure you select Create Diagram instead of Create for the behavior of the action.  

• To add the new diagram to the list, click on  from the bottom of the column 

screen. 

• Enter Name and Description of the new diagram, then click on Add. 
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 Make sure you select Create Diagram instead of Create for the behavior of the action.  

 

Automated Diagrams 

Automated Diagrams are the in-built diagram models, which reads the data from the source. These 

diagrams come along with the package or model. 

Built in we have 3 layouts called Hierarchy, left to right & box in box.  

These auto-diagrams require a diagram template and can be configured to make them look just right. 
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Network View 

Network View helps to show the relational data of the Object Type following the metamodel relationships. 

Network View is typically applied when rendering the context from a single object instance. 

An example for the Network View is shown below: 

To create Network View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views.  

2. Select Network View from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

 

4. To add the steps to the Network, click on Configuration of Network View. 
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Go to Network Steps > Add Step > Enter Label > Select Relationship Type > select Target Object 

Type > Add. 

 

 

 

 Ticking the Ignore checkbox will still draw the step but will not return the results of that step. 

To group the step, tick the checkbox Group. 

5. A child step can be added further to the associated Objects. 

To add the child step, click on three dots against the main step. 

Select Add Child Step. 

 
6. A preview of the configured Network is shown in the picture below. 
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Make sure you know the relationships between the objects before configuring the Network View. To know 

the existing relations, go to Profile > Relationship Types. 

 

 
Network View can also be configured as Object Type View, but it requires context to pass from source. To 

know, see Object Type View. 
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Tree View 

Tree View help to visualize the relational data hierarchies of the objects. 

To create Tree View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Tree View from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Apply the Title Properties, Thumbnail Property and Tooltip Property as required. 

 
 

4. Defining Data Source is the first step for the Tree View. To add the next level step. 
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Click on Tree Steps > Add Step > Enter Label > Choose Relationship Type > Select Target Object 

Type. 

Click on Add. 

  

 Ticking the Ignore checkbox will still draw the tree step but will not return the results of that step. 

 

5. To see the step, click on an arrow against the source. A Preview of the configured Tree View is shown 

in the picture below. 

 
 

6. A child step can be added further to the associated Objects. 

To add the child step, click on three dots against the main step. 

Select Add Child Step. 
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Enter Label > Relationship Type > Target Object Type > Add. 
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Roadmap View 

Roadmap View help to visualize the data journey over a while. 

To create Roadmap View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Roadmap from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display. 

• Apply the Properties, Title Property according to the view. 

• Click Preview to see the result. 
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4. To apply the properties,  

• Click on Properties > Add Property. 

• Select Source and the Property. 

• If Start Date is selected, enable End Property, and select the Source and Property. 

• Select Color of you wish to apply and click on Apply Changes. 

 

 
5. Click Preview to see the configured Roadmap View. 
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To create a Roadmap view, you do not need to have both dates. It can also display with single points in time 

i.e., start date. 
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Calendar View 

Calendar View help to keep track of upcoming events, appointments, and meetings reflected in the model with 

the date/time attributes. 

To create Calendar View, 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Calendar from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display. 

• Apply the Properties, Title Property and Tooltip Property according to the view. 

• Click Preview to see the result. 
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4. To apply the properties,  

• Click on Properties > Add Property. 

• Select Source and the Property. 

• If Start Date is selected, enable End Property, and select the Source and Property. 

• Select Color of you wish and click on Apply Changes. 

 

5. Click Preview to see the configured Calendar View. 

 

 To create a Calendar view, you must define the Start and End properties and those should be dates. 
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Special Views under Collections 

Special Views are the part of the Collection Views, which works with any View type or an Object Type 

View. 

The configuration of these special views is similar except the appearance. 

To see how to configure these special views, visit the below mentioned topics. 

• Accordion Collection 

• Carousel Collection 

• Tab Collection 

• Card Collection 
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Accordion Collection 

Accordion Collection is a data driven view, allows you to see, navigate and interact with the model. 

Using Accordion can categorize a form, or to create a flow to information. 

To create Accordion Collection, 

6. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

7. Choose the preferred layout. For instance, choose a Menu. 

Click on +Add Content and then select Accordion Collection. 

 
8. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display if needed. 

• Apply the Properties according to the view. 

• Click Preview to see the result. 
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9. Now click on +Add Content to add the view type you wish to.  

• For instance, in the below example a List and a Pie Chart is selected.  

• For each view, select Data Source, and the Element Type. 

• Apply other properties and limit if required. 
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10. This Configuration of List and Pie Chart will be displayed for all Accordion items.   
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Carousel Collection 

Carousel Collection cycles through the selection of views defined by application Data Source.  

The Configuration process of Carousel is similar to the Accordion Collection.  

To configure the Carousel Collection, see Accordion Collection and repeat the steps by selecting Carousel 

instead of Accordion. 

The preview of the configured Carousel Collection is shown in the below picture. 

 

 

 

The above is configured with the Object Type View. You can configure more by selecting 

any view type. 
 

 

 

 

Carousel items cycles one after the other. To know more, see Carousel Layout. 
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Tab Collection 

Tab Collection is used to separate different concerns on a page.  

The Configuration process of Tab is similar to the Accordion Collection.  

To configure the Tab Collection, see Accordion Collection and repeat the steps by selecting Tab instead of 

Accordion. 

The preview of the configured Tab Collection is shown in the below picture. 
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Card Collection 

Card Collection allows to visualize and interact with multiple objects on the page at once.  

The Configuration process of Card Collection is similar to the Accordion Collection.  

To configure the Card Collection, see Accordion Collection and repeat the steps by selecting Card instead 

of Accordion. 

The preview of the configured Card Collection is shown in the below picture. 
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Charts 

Chart Views works with data analysis to condense a large amount of data into an advanced visualization. 

The choice of Chart type depends upon the metrics and the properties of the Object. 

The Charts available to handle the data visualization are: 

1. Count 

2. Count Comparison 

3. Word Cloud 

4. Bar Chart 

5. Pie Chart 

6. Line Chart 

7. Radar Chart 

8. Scatter Chart 

9. Pivot Table 
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Count 

Count View helps to display the data by highlighting a specific piece of information or metric in a card. 

To create a Count View: 

Count Views are best to apply along with the layout.  

E.g., with the combination of Row and Column Layout. 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Choose the preferred layout. For instance, choose a Column Layout.  

By default, a layout with two columns will appear. Click on + Add Content. 

 
Select Count from the list. 

 
 

3. To configure the view, click on Configuration on the toolbar or right-click on the view to see the list 

and then select. 
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After configuration of your own element type choice, the preview of the view looks like as shown in 

the picture below. 

 

 You can create custom data sources to return specific queries using Filters.  

E.g., How many element types have an attribute set to true. 

 

4. You can set the Intervals to change the color of the count. An icon will be displayed, once the 

returned metric hits a user-defined number. 

To set an Interval, 

• Go to Configure on the toolbar and then select Intervals or by right-clicking on the view. 

• Click on Add Interval from a section that appears on the right side of the screen. 

• Enter Minimum and Maximum Values of the Interval. 

• Select the Icon and Color. 

• Click on Apply Changes. 
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Count Views looks as shown in the figure below. 
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The appearance of Count View can be customized in three ways with the help of Card Style. 

To apply the style, click on the Card Style icon on the toolbar or right-click on the view, you wish to apply.  

 

• Colored Card – displays with a different choice of colors. 

 
• Card – is a simple card type with transparent background. 

 
• Circular – is a Card Style displayed in the colored annulus. 
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Count Comparison 

Count Comparison View helps to display the count compared to the set of results of two different queries 

which often displays one value out of another. 

Configuration of Count Comparison is much like the Count View which is always displayed as an absolute 

value. It is during the configuration of color change on intervals that will be triggered as an Absolute value 

or Percentage. 

To create a Count Comparison View: 

Count Comparison Views are best to apply along with the layout.  

E.g., with the combination of Row and Column Layout. 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Choose the preferred layout. Click on + Add Content > + Add New View > Select Count 

Comparison from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or select Filter, for both 

Numerator and Denominator. 

• For Instance, select filter for the Numerator and the element for the Denominator. 



    

 

 

erwin Evolve 360- User Help Guide 
80 

Charts 

 

 

 

 

 

4. You can set the Intervals to change the color of the count and to display an icon. 

To set an Interval, 

• Go to Configure on the toolbar and then select Intervals or right-click on the view to 

select. 

• Select Absolute if the returned Numerator value falls between the two values.  
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• Select Percentage if the Numerator value falls between the two portions of the overall 

denominator percent. 

 
• Click on Add Interval from a section that appears on the right side of the screen. 

• Enter Minimum and Maximum Values of the Interval. 

• Select the Icon and Color. 

• Click on Apply Changes. 

5. To apply the style, click on the Card Style icon on the toolbar or right-click on the view, you wish to 

apply. You can choose the preferred style either in Card or Circular as shown in the figure below. 
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Word Cloud 

Word Cloud is a visualization format that highlights the important and specific words of the Element. 

Word Cloud is not only for the specific element type, but a query can also be defined or can select the list 

stored in the application. 

To create a Word Cloud View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Word Cloud from the list of charts. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Click Preview to see the result. 

 
4. By default, the Property is set with Name. Thus, Preview displays the names of the selected 

Element Type as shown in the picture below. 
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erwin Evolve 360- User Help Guide 
84 

Charts 

 

Bar Chart 

Bar Chart helps to represent categorical data using the number of bars. 

To create a Bar Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Bar Chart from the list. 

 
3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

Refer to the image below to see how Bars can be Grouped or Stacked and can be viewed 

in Horizontal/Vertical bars. 

 

• Select Data Source, either Element Type for a new one or Filter. 
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• Set Limit to display. 

• Apply the Properties, Tooltip and Title Property according to the view. 

• Click Preview to see the result. 

 

4. By default, a Property is set with Name. It is mandatory to set the property according to the Data 

Source. 

To add the Properties,  

• Click on Properties. To add the new one, click on Add Property or click on the existing 

property to edit. 

 
• Select Source Element Type > Property. 

• Click on Apply Changes. 
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 Properties applied must be Numeric. 

 

5. The preview of the configured Bar Chart is shown in the picture below. 

 
6. To display the Stacked Bar Chart, two or more attributes should be added to the Properties. 

To view the Stacked Bar Chart, click on the icon  on the toolbar. 

A preview of the Stacked Bar Chart with three attributes is shown in the picture below. 
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Pie Chart 

Pie Chart helps to represent proportions of data. 

To create a Pie Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Pie Chart from the list. 

 
 

3. To configure the view,  

• Click on Configuration on the toolbar or right-click on the view. 

• Select Data Source, either Element Type for a new one or Filter. 

• Select Properties to group. 

 

• Click Preview to see the result. 
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Line Chart 

Line Chart helps to compare multiple numeric attributes. 

To create a Line Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Line Chart from the list. 

 
 

3. To Configure the Line Chart, 

• Click on Configuration on the toolbar or right-click on the view to select. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display if needed. 

• Applying Properties is must to configure the Line Chart. 

• Click Preview to see the result. 
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• To add the Properties, click on +Add Property 

• Select the Data Source, and the Property. 

• Click on Apply Changes. 

• The preview of the configured Line Chart is shown in the picture below. 

 

 

 Properties selected must be Numeric. 
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Radar Chart 

Radar Chart helps to present multivariate data by comparing multiple numerical attributes. 

To create a Radar Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Radar Chart from the list. 

 
3. To Configure the Radar Chart, 

• Click on Configuration on the toolbar or right-click on the view to select. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display if needed. 

• Applying Properties is must to configure the Radar Chart. 

• Click Preview to see the result. 

 

• To add the Properties, by default the property is set with a Name.  
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• To add the new property, click on +Add Property 

• Select the Data Source, and the Property. 

• Click on Apply Changes. 

• The preview of the configured Radar Chart is shown in the picture below with the 

properties. 

 

 

 

 
Multiple properties can be added to compare the attributes between them. And the Property selected must 

be numeric. 

 

4. Radar Chart can be customized further.  

• To apply the Radar Fill as Opaque or Transparent, click on  from the toolbar. 

• To apply the chart type as Analyze Elements or Analyze Attributes, click on  

from the toolbar. 
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Scatter Chart 

Scatter Chart helps to visualize trends between two datasets. 

To create a Scatter Chart: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Scatter Chart from the list. 

 
3. To Configure the Scatter Chart, 

• Click on Configuration on the toolbar or right-click on the view to select. 

• Select Data Source, either Element Type for a new one or Filter. 

• Set Limit to display if needed. 

• Applying X and Y Axis Properties is must to configure the Scatter Chart. 

• Click Preview to see the result. 
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4. To add properties on X and Y Axis. 

• Click on X Axis > Select Data Source > Property. 

• Click on Y Axis > Select Data Source > Property. 

5. The preview of the configured Scatter Chart is shown in the picture below with the properties. 

 

 

 

 Properties selected must be numeric. 

6. To set the origin to Zero or the start of the dataset, click on icons  and  

respectively. 
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Pivot Table 

A Pivot Table allows you to extract the significance from a large, detailed data set.  

To create a Pivot Table: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. Select Pivot Table from the list. 

 
3. Click on Configuration on the toolbar or right-click on the view to select. 

 
4. After Configuration, click on Preview placed on the top right corner to see your configured Pivot 

Table. 
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Item Views 

Items Views help to see the specific information by highlighting what is important and let you interact at a 

granular level. 

Item Views are typically applied to the Object Type Views where they work when taking the context from a 

single source. Also, they can be configured with any layout to display the specific information in different 

views. 

The available Item Views are: 

1. Forms 

2. Property Card 

3. Property Pie Chart 

4. Property Radar Chart 

5. Property Comparison 

6. Property Display 

7. Comments 

8. Attachments 
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Form 

Forms are a basic way of displaying and editing properties of an object instance of data, used to display and 

edit the properties. 

To create a Form: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Form works like an Object Type View which returns the context from a single source. or 

A Column layout is chosen for an instance with a List View in the first column. 

3. To add Form in the second column, 

Click Add Content > Add New View > Select Form. 

 

 
4. To pass the context from the source, 
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• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 

 

• Click Context Source > Select Internal > Apply Changes. 

 
5. To add the Properties to the Form, click on Configuration from the toolbar or right-click on the view. 

Click Add Property > Select Property. 

Select the checkbox Editable if you wish to edit the property in the Form. 

Click on Apply Changes. 

 

 Note: Multiple properties can be added to the Form. 
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Property Card 

Property Cards are a way of displaying and interacting with individual pieces of data. 

To create a Property Card: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Property Card works like an Object Type View which returns the context from a single 

source. 

For an instance, a Row layout is chosen, and configure a List View in the first row. 

3. To add Property Card in the second row, 

Click Add Content > Add New View > Select Property Card. 

 

 
4. To pass the context from the source, 

• Click on the title of the layout and then Configuration from the toolbar. 

• Click Row 2. 
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• Click Context Source > Select Internal > Apply Changes. 

 

 The height of the Row can be adjusted manually by disabling Autosize and then enter the value in the field. 

5. The Preview of the configured Property Card is shown in the picture below. 

By default, the property is set with Name. You can add the additional properties to the card by Add 

Property for the new one.  



    

 

 

erwin Evolve 360- User Help Guide 
103 

Item Views 

 

Property Pie Chart 

Pie charts help to visualize proportions between attributes. 

To create a Property Pie Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Property Pie Chart works like an Object Type View which returns the context from a single 

source. 

For an instance, a Column layout is chosen, and configure a List View in the first column. 

3. To add Property Pie Chart in the second column, 

Click Add Content > Add New View > Select Property Pie Chart. 

 

 
4. To pass the context from the source, 

• Click on the title of the layout and then Configuration from the toolbar. 
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• Click Column 2. 

 

• Click Context Source > Select Internal > Apply Changes. 

 

5. To configure the Property Pie Chart, click on Configuration from the toolbar or right-click on the 

view. 

By default, the property is set with Name. Edit the property or click Add Property for the new one. 

 
6. The Preview of the configured Property Pie Chart is shown in the picture below. 
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Property Radar Chart 

Property Radar Chart is useful for comparing multiple numeric attributes. 

To create a Property Radar Chart View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Property Radar Chart works like an Object Type View which returns the context from a 

single source. 

For an instance, a Column layout is chosen, and configure a List View in the first column. 

3. To add Property Radar Chart in the second column, 

Click Add Content > Add New View > Select Property Radar Chart. 

 

 
4. To pass the context from the source, 
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• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 

 

• Click Context Source > Select Internal > Apply Changes. 

 
5. Attributes need to be added to complete the view.  

To configure the Property radar Chart, click on Configuration from the toolbar or right-click on the 

view. 

By default, the property is set with Name. Edit the property or click Add Property for the new one. 

 Note: Properties added must be numeric. 
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6. The Preview of the Property Radar Chart with three defined properties. 
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Property Comparison 

Property Comparison helps to compare two attributes or metrics in a card. 

To create a Property Comparison View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Property Comparison works like an Object Type View, which returns the value of the two 

attributes in a single instance. 

A Column layout is chosen for an instance and a List View in the first column. 

3. To add Property Comparison in the second column, 

Click Add Content > Add New View > Select Property Comparison. 

 

 
4. To pass the context from the source, 
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• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 

 

• Click Context Source > Select Internal > Apply Changes. 

 
5. To configure the Count Comparison, click on Configuration on the toolbar or right-click on the view. 

Select the Property for both Numerator and Denominator to see the compared attribute values. 
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Property Display 

Property Display highlight a specific piece of information or a metric in a card. 

In simple words, it displays the single property of the object. 

To create a Property Display View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2. As the Property Display works like an Object Type View which returns the context from a single 

source. 

A Column layout is chosen for an instance and a List View in the first column. 

3. To add Property Display in the second column, 

Click Add Content > Add New View > Select Property Display. 
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4. To pass the context from the source, 

• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 

 

 

• Click Context Source > Select Internal > Apply Changes. 

 
5. Click on Configuration of Property Display and select the property you wish to display. 
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Comments 

Comments allow users to easily discuss within the context of a specific element. 

To create a Comments View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2.  Comments works like an Object Type View which returns the context from a single source. 

Consider any layout. For instance, chose a Column Layout and configure a List View in the first 

column. 

3. To add Comments in the second Column, 

Click Add Content > Add New View > Select Comments. 

 

 
4. To pass the context from the source, 

• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 
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• Click Context Source > Select Internal > Apply Changes. 

 
5. The Preview of the configured Comments is shown in the picture below. 
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Attachments 

Attachments allow file sharing in a specific context. 

To create an Attachments View: 

1. Click on All Views in the editor and then click on  icon placed at the bottom of the list of views. 

2.  Attachments works like an Object Type View which returns the context from a single source. 

Consider any layout. For instance, chose a Column Layout and configure a List View in the first 

column. 

3. To add Comments in the second Column, 

Click Add Content > Add New View > Select Comments. 

 

 
4. To pass the context from the source, 
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• Click on the title of the layout and then Configuration from the toolbar. 

• Click Column 2. 

 

• Click Context Source > Select Internal > Apply Changes. 

 
5. To add Attachments to the view 

• Click on + Add Attachments. 

• Enter Name, Description and Upload File. 

• Click on Add. 
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6. The Preview of the Attachments is shown in the picture below. 

The Attachments are stored against an object instance 

You can Edit, Delete the uploaded Attachment, and can Add the new one. 
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Miscs 

Rich Text 

Rich text is used to create the information pages with the help of the built-in editor. 

Rich Text works along with any layout. 

To configure the Rich Text, 

1. Choose Rich Text view type in any layout you wish. 

2. Click on Edit Text on the toolbar, this opens the text editor. 

• Write the text in the space and can customize the text as you do in the word editor. 

• You can add Links, Images and can construct the Table by defining rows and columns. 

• When you finish with the editing, click on Apply Changes. 
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Image 

Image View allows to upload the images for use in an application. 

Image works along with any layout and the properties of the image can be configured with the individual 

view type too. 

To configure the Image, 

1. Choose Image view type in any layout you wish. 

2. Click on Configuration on the toolbar, upload the Image on the right-hand side panel. 

 

 

 Image also available to add as the icon for the list of items, or in the properties of specific sources. 
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To add Object Type View 

Object Type View helps to display the information rendered from the Element Source Type. 

An example of configuring Object Type View in the Column Layout: 

Go to All Views in the editor and choose the default Column Layout. 

To add the content in the columns.  

Click on + Add Content > Add New View. 

 

For instance, choose a List view in one column and its Object Type View in another column, as shown 

below. 

Comes a Video. 

To Configure the Views in columns,  

1. Select the view to configure. 

2. Click on Configuration on the toolbar or right-click on the view. 

3. Select Data Source Type. E.g., Select Element Type from the list. 

4. Select Element Type. E.g., Select DIS Business Term. 

5. Click on Preview to see from the right upper corner of the page. 
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Warning Symbol before the Configuration represents that the view selected is incomplete and requires 

action. 

 

A column with Object Type View requires context, which must define the property such that the information 

will be rendered to display. 

 This action can be performed in the Preview mode or go back to the Design mode 

To pass the context to the Object Type, 

1. Click on the title of the Layout. 

2. Click on Configuration on the toolbar or right-click on the view. 

3. Click on Column 2 from the right-side pane. 
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4. Select the Context Source as Internal. 

5. Click on Apply Changes. 

 

Element List and its Object Type details are displayed as shown in the picture below. 
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The columns can be customized as per the use cases. It can be chosen any sort of Collection Views like 

Charts, Kanban Boards, Tables, etc.. 

 

 
There are two types of Context Sources to render the information of the elements. Internal source is 

considered when the information is rendered within the Layout. If the information of the element is to be 

rendered from the outside of the Layout, then the External Source must be selected. 
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Customization of View 

Customization of a view can be performed by applying Filters, Events, Heatmaps, Overlay Filters, Actions, 

Headings. 

Filters 

Filters are applied while configuring the view to display the data, which can be applied in two ways. The first 

is defining the new set of filters using Filter Criteria, and the other is applying the already defined filter 

using the Existing Filter. 

Steps to apply Filter Criteria: 

For instance, in a list view, Filter Criteria is applied to Data Source Type to extract the necessary list of 

items based on the Object Type's Properties. 

1. Click on view under the Layout, go to Configuration, which appears on the pane's right side. 

    
By default, Data Source Type will be None. 

2. Select the Filter Criteria under the Data Source Type. 

 
An option to edit will show up right after the selection. 
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Click on Edit Criteria. 

A dialog with the editor opens, choose the Object Type for a selected view and properties of that 

object. 

Click on Apply Changes to save. 

 

 

 

With Filter Criteria, multiple Object Types and Properties can be added or deleted by clicking on the  

icon or  icon against the entry. 

 

Steps to Apply Existing Filter: 

1. Click on view under the Layout, go to Configuration, which appears on the pane's right side. 
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2. Select Existing Filter from the list. Choose the desired filter to apply in the view. 
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Events 

Events help the users define what happens and what view appears when the interact with an element in the 

view.  

For example: Open a panel displaying the object type view if they click on a row in a table 

Events can be found under Configure tab or on the toolbar. 

 

There are two types of behaviors for an Object Type. 

1. Trigger Context – is used to pass the Object Type selected to the other view.  

E.g., In the below example, the Element Type defined passes the object and displays it in the 

Object Type View within the Layout. 
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2. Open View – It opens the Object Type View in Window, Dialog, Panel and Tab.  

Dimensions of the View can also be customized by giving the Height and Width. 

   
The Initial State of the View can be set in different ways, i.e., Floating over the screen, in Full 

Screen, Snapping to the left, right, top and bottom. 
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Heatmaps  

Heatmaps help to highlight the required information of the Element Type. 

To add the Heatmaps, click on the  icon in the toolbar or find under the tab Configure. 

 

A popup appears on the right side of the pane.  

1. Click on Add Heatmap. 

2. Click on three dots against the New Heatmap. 

   
3. Click on Edit, a dialog box appears. 

Input the Label and choose Filter Criteria, then click on Edit Criteria. 
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Choose the Object Type and enter the properties of the object to display. 

 

For instance, select Object Type as DIS Business Term and property as Name – Starts with C. 

Then click on Apply Changes. 

 
4. Applied Heatmap appears as a breadcrumb over the top of the view by highlighting the information. 
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Overlay Filters 

Overlay Filters are applied to filter the data within the view of the Layout. 

To apply the Overlay Filter, click on the  icon in the toolbar or find under the tab Configure. 

 

 

A popup appears on the right side of the pane.  

1. Click on Add Overlay Filter. 

2. Click on three dots against the New Filter. 

  
3. Click on Edit, a dialog box appears. 

Input the Label and choose Filter Criteria, then click on Edit Criteria. 
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Choose the Object Type and enter the properties of the object to display. 

 

For instance, select Object Type as DIS Business Term and property as Name-Starts with B. 

Then click on Apply Changes. 

 
4. Applied Filter appears on the top right of the view. 

Select the required filter to see the data. 
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Header Style 

To add Header Style to the view,  

1. Go to Style tab on the toolbar, then select Header Style. 

 
2. By default, the style selected would be None. Select the Header Style from the drop-down you wish 

to apply. 

 
• Small and Large are Header Styles differ with the font sizes. 

 
 

• Context Object is the style that renders the display name from the Element Source. 

Context Object style is typically used for the Object Type View. 
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In the above example, the list of elements displayed in the first column and its Object Type View is 

defined in the second column. By selecting the style Context Object, a selection of individual 

elements is displayed for its Object Type. 

 

3. To apply the Underline to the Header, go to tab Style and then select Show header Underline. 

 

 
Show Header Underline option will be visible only after you select Header Style other than none. 

4. To apply Color to the Header line, 

• Go back to the tab Style then select Header Underline Color. 

• Choose your desired color. 
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Diagramming 

Overview of Diagrammer 

Diagrammer is used to both edit and create any Evolve Diagram online. 

 

The different features within the Editor are detailed below: 

Diagram Title 

Editable title for the diagram, this 

differs from the diagram name, 

which must be unique 

Click to rename the title 

Zoom Controls 

Zoom % - Click to choose presets 

Zoom in and out - [+] and [-] 

Zoom Slider 

Radar button 

Click and move the 'Radar' view to 

zoom around the diagram. 

All can be collapsed to a single 

magnifier button. 
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Shape Palette 

The Shape Palette contains all the 

shapes that can be used on the 

diagram. 

 

Drag and drop the shapes from the 

palette onto the diagram surface 

  

Note that lines / connectors are 

drawn from the (+) buttons around 

the sides of a selected shape. 

 

Shape and Diagram 

Tools 

Home to the different panes in 

Diagrammer: Properties, To Do, 

Diagram Settings, Palette &Styles 

and Deleted Objects. 

 

Canvas Area 
The area where the edited/created 

Process Diagram will display. 
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Navigation 

Diagrammer controls that can be used when editing a diagram. 

Click Summary 

Mode Click 

Type 

Behavior 

Standard 

Single 
Selects a shape and updates the "Shapes and Diagram Tools" pane for that 

Shape/Connector, if the pane is open. 

Double 
Opens the "Shapes and Diagram Tools" pane, if it is closed, and navigates to the 

Name and Properties tab. For easy access to the object details. 

Keyboard Shortcut Summary 

Keyboard Shortcut Behavior 

Ctrl+ + Zoom In 

Ctrl+ - Zoom Out 

Esc Deselect all shapes 

Delete Deletes or Clears the selected Shape(s)/Connector(s) 
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Formatting Shapes in Diagrammer 

Adding Shapes, Connecting Lines to the Diagram, and Changing Properties 

To add shapes to the diagram, 

1. Drag and drop the required shape from the Shape Palette. 

2. Double-click on the object shape to edit the Title and its Properties. 

3. Click Save. 

 

You can use a Connector to link two Shapes, indicating that there is a connection between the two 

shapes. 

To add the connector between the shapes, 

1. Select the first shape by clicking on it. 

2. Click on one of the + symbols to add the connector and move your mouse pointer to the shape you 

would like to connect to. 

3. Click on the shape to end the selection. 

4. If there are multiple connection types between these kinds of objects, you will get a menu to choose 

the connection that is appropriate.  

To Clear or Delete Shapes from the Diagram 

Object Shapes can be Cleared or Deleted from the diagram in two ways. 

 To Clear a Shape: 

When you choose to Clear a shape, it removes the shape from the diagram, but it does not remove the 

object it represents from the model. 

1. Select the shape you wish to Clear. 
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2. Click on   icon. 

  

 

  

To Delete a Shape: 

When you choose to Delete a shape, it removes the shape from the diagram, and when published 

will remove the object representing from the model too. 

1. Select the shape you wish to Delete. 

2. Click on   icon. 

  

 

 If a shape is deleted, any connector associated with the object shape also gets deleted. 

 

 
When object shapes are deleted using the Delete option, it adds the item to the Trash can icon 

called Deleted Objects on the right-hand pane. 
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Adding Background Colors and Borders to the Shapes 

Every Shape from the Palette has a definite background color, border size, and border color. 

You can format the shape by 

1. Background Color of the shape. 

2. Border Size to the shape. 

3. Border color to the shape. 

 

 

 
When object shapes are deleted using the Delete option, it adds the item to the Trash can icon Some 

shapes may have Region shapes and Region formatting which overrides these styles such that the style 

options will not work. 

 

Example: A shape may be set with color because of the “Category” of the object, i.e. the shape may 

be Red because it is a critical object (as defined in one of its properties). 

 

Aligning Shapes 

Object shapes in the editor can be aligned using Align Nodes placed on the toolbar. 

       

Object shapes can be aligned to the Left, Right, and Center horizontally, and also Top, 

Bottom, and Center vertically, which can also be evenly Distributed Horizontally or Vertically. 
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Resizing Shapes to match others 

In the Diagrammer, the object shape can be adjusted to the height and width of the other shape 

using Resize Nodes. 
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Move Shapes from Back and Front 

In the diagram, if one shape is put on top of another, it may conceal the other. 

Move To Back and Move To Front buttons help to show/Hide the object shape. 

   

Text Formatting and Fonts 

The Title of Object shapes can be formatted according to: 

1. Font and its Font Size 

2. Text in Bold, and Italic 

3. Text alignment to Left, Center, and Right. 

4. Vertical Alignment. 

5. Text Color. 

 

 
Some shapes may have Region shapes and Region formatting which overrides these styles such that the 

style options will not work. 

 

Example: A shape may use a different property for the Title, that is defined in a region. This region’s style 

cannot be overridden by Diagrammer 
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General Operations in Diagrammer 

Options that are generally available for any diagram in the canvas are: 

1. Duplicate Draft 

2. Publish Diagram 

3. Download Diagram 

Duplicate Draft: 

To duplicate the working draft of the diagram, click on Duplicate Draft on the toolbar. 

 

By doing this, a copy of the draft will be created, and you will be taken immediately to the draft diagram. 

The draft diagram will be associated with the originally published diagram, and on publishing will replace the 

same published diagram. 

 To create a separate published diagram, you should duplicate the published diagram instead 

Publish Diagram 

To publish the diagram, click on Publish Diagram icon on the toolbar. 

 

Before proceeding to Publish the diagram, make sure you don’t have any incomplete items in To-Do list. 

Once published, the draft diagram will be deleted, and the published diagram will be available in the 

application. 

Download Diagram 

To download the diagram in the form of an image to your machine, click on Download Diagram on the 

toolbar. 

 

Diagram Settings 

To apply the settings related to the diagram Grid, Animation and Guiding lines in the editor, click on 

Diagram Settings on the toolbar. 

 

You will see a panel popped up on the right-side of the screen to work on settings.  
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Working with Connector Lines 

The lines which associate the two objects in the diagram are called Connector Lines. 

 

Double-click on the line, then the options for connector lines are shown on the toolbar. 

 

Lines can be applied in two ways: 

1. Direct Route – connects the objects using the shortest path. 

2. Avoid Route – connects the objects avoiding the other objects in the diagram structure. 
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Lines are of three types are available to connect the objects: 

1. Orthogonal Lines – Orthogonal Lines are when the line appears with right angles in order to 

connect the two objects when it cannot be drawn horizontally or vertically. 

This line is available only under Direct Route and will be disabled for Avoid Route. 

 

Orthogonal Off Orthogonal On 

 

 

 

2. Jump Lines – Jump Lines are when one connecting line passes over another, and it appears with an 

arc over it. 

This button is used in conjunction with the orthogonal lines button. If an orthogonal line is off for a 

particular line, then the jump line button is disabled. 

 

Jump is a property of an individual line, so if the lines cross and neither have the jump property then 

they look like straight lines passing through one another. Jump lines will be seen if both lines have 

jump property.  

3. Lock/Unlock Link Port – Link Ports can be Locked or Unlocked. To lock them, either press the 

button or move the connection point (port) of the line, around the shape. When you select a location 
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to port the line to the shape, it will become locked. If you want the Diagrammer to automatically 

reposition the port, select the line, and press the unlock button, to release the lock. 

Locking the link ports helps to keep the specific connection point when the shapes are moved 

around the canvas. 

 

  



    

 

 

erwin Evolve 360- User Help Guide 
148 

Administration 

 

Administration 

Client and User Settings 

Client & Users helps to add new user, license management, and to register requests. 

 

You need to have administrator rights to perform any action related to users. 

 

To set the settings, go to profile icon on the top right corner, select Client & Users. 

 

 

1. To set the existing user with Administrator rights,  

Go to Client > Administrator > Save 

 

2. Under License tab, you can view your available Licenses for the product. You can assign licenses to 

registered users by clicking on User in the table and to remove the license for the assigned user, 

click on cross against the user on selection. 
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3. Registration Requests tab helps to register the new users. 

Click on + symbol on top of the table, enter the Email address of the user and click on Save. 

 

Soon after, user will receive a Registration Request email saying that an account has been created 

and asks to Activate Account. 

4. Users display the whole list of registered users with the license information. 
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Communities 

Communities are a defined set of users identified as group of individuals or teams, that work together to 

achieve a common goal. 

By default, an object will not have any communities and therefore visible to all users. 

In Evolve 360, Communities are of two types. These community types control the access of communities to 

concepts within the platform. 

• Public – visible to every user 

• Private – visible only to those within it and will be hidden from users who is not a member 

How to create a new Community? 

 

A user with administration rights will only have a privilege to create a community. 

To create a new Community, 

1. Go to profile and then select Communities. 

 
2. A screen appears with the list of communities on the left-hand side and its details on the right-hand 

side upon selection of community. 
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3. To create a new community, click on  button at the bottom of left-hand side screen. 

4. Enter the details in the form on the right-hand side of the screen. 

i. Set the Community to be either Public or Private. 

ii. Enter the Name for your new community. 

iii. Choose an Administrator from the list of users. 

iv. Select the members you wish to be a part of community. 

 

5. Click on Save to finish. 
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How to Add/Remove users to an existing 

Community? 

1. Go to profile and then Communities. 

2. Select the community from the list appeared on the left-hand side of the screen, then its details will 

be shown on the right-hand of the screen. 

3. Click on Members, check the box against the name of the user you wish to add or uncheck the box to 

remove the user. 

 
4. Click on Save to finish. 
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How to restrict a view to single Community or 

set of Communities? 

An administrator has the access to restrict a view to a certain community or set of communities.  

To restrict a view, 

1. Go to application editor of the view you wish to restrict. 

2. Go Configure and select View Display Control. 

 
3. A screen will be shown up with the details. 

i. Select the Communities you wish to restrict the view to by clicking on their names. 

ii. Select the Data Source to include with the context. 

iii. Click on Apply. 

 

 
 

 
If no Communities are selected, it displays to all users, or it displays only to the selected communities. 

A data source of None mean that will always display. When a data source is selected it only displays when 

the context item is included in this data source. 
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Import/ Export 

Import and Export are the bulk operations deals with your application data.  

Import 

To Import the data, 

1. Go to Profile, click on CSV Import. 

 
2. A screen appears with the list of imports, and their status. 

 

3. To create a new Import, click on  button from the bottom of left-hand side of the screen. 

4. Enter the fields in the screen that is presented. 

i. Select Column and Value Delimiter. 

ii. Either drag your file into the selection box or Click to Upload the file. 

5. Once the file uploaded, it is added to the import queue.  

You are then able to track the progress of the import and can view logs after completion. You can 

also see a report of what errors have occurred. 
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Import operation requires a file with the specific format. Make sure you have that format before importing 

the file. 
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Export 

To Export the data, 

1. Go to Profile, click on CSV Export. 

 
2. A screen appears with the list of exports, their status, and a download link of the file. 

3. To create a new Export, click on  button from the bottom right corner of the screen. 

4. Enter the fields in the screen that is presented. 

iii. Select Column and Value Delimiter. 

iv. Select your Object Type. 

v. Click on Create. 

 

5. You will receive an email after successful export. 

 

 
You can select single or multiple object type and define further criteria. E.g., Status equals or has a 

relationship with some object. 
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   About Us 

Quest creates software solutions that make the benefits of new technology real in an increasingly complex 

IT landscape. From database and systems management to Active Directory and Office 365 management, and 

cyber security resilience, Quest helps customers solve their next IT challenge now. Around the globe, more 

than 130,000 companies and 95% of the Fortune 500 count on Quest to deliver proactive management and 

monitoring for the next enterprise initiative, find the next solution for complex Microsoft challenges and stay 

ahead of the next threat. Quest Software. Where next meets now. For more information, visit 

www.quest.com. 

Technical support resources 

Technical support is available to Quest customers with a valid maintenance contract and customers who 

have trial versions. You can access the Quest Support Portal at https://support.quest.com. 

The Support Portal provides self-help tools you can use to solve problems quickly and independently, 24 

hours a day, 365 days a year. The Support Portal enables you to: 

i. Submit and manage a Service Request 

ii. View Knowledge Base articles 

iii. Sign up for product notifications 

iv. Download software and technical documentation 

v. View how-to-videos 

vi. Engage in community discussions 

vii. Chat with support engineers online 

viii. View services to assist you with your product. 

 

 

https://www.quest.com/
https://support.quest.com/

