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Solution SOL58640

Title

QCS (Quest Collaboration Services) is experiencing "Access is Denied" errors on Schedule + FB Public Folders

Problem Description

While synchronizing FB data the following errors can be traced in the logs:

29/10 12:03:46:627 | ReadyCacheTableFunctor.cpp(79) | 244  | Collecting: /O=ORG_NAME/OU=AG/CN=RECIPIENTS/CN=EXCHANGE USERS/CN=TEST1
29/10 12:03:46:627 | ReadyCacheTableFunctor...(110) | 244  | Error:  Access is denied. 0x80070005

However when using MFCMAPI or Outlook and logging into QCS mailbox under the service account all the FB information can be successfully observed.

Cause

QCS opens FB messages with the MODIFY flag and therefore this problem is not easily reproduced. All FB messages can be seen in the environment however QCS would still experience Access Deny condition during FB sync. Here are the steps to reproduce (please also see MS Word document with screenshots attached):

1. Launch MFCMAPI and log into QCS mailbox under the service account credentials.
2. Open Public Store and browse to the corresponding Schedule + F/B Public Folder. Open Content Table.
3. Copy PR_EntryID value of one particular FB message.
4. Perform Property Pane | Selected Property | Open by EntryID or Object with the "PASS_MODIFY" checkmark enabled. This should return Access Deny error code 0x80070005.

Resolution

Please ensure that Default Exchange client permissions on Schedule + F/B folders are set to Editor. This is Microsoft default configuration. Such modification can be performed with the following tools:

1. Exchange 2003 Exchange System Manager (ESM).

2. PFDavAdmin.

3. Exchange Management Shell with PowerShell in Exchange 2007 as per this Microsoft article:
http://technet.microsoft.com/en-us/library/bb310789.aspx

Environment

Product: Collaboration Services
Attachments: MFCMAPI.docx
Client OS:
Server OS:
Database:
Application:

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