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Solution SOL42144
Title
Problem Description
What are some important things to consider when configuring Free/Busy synchronization between Exchange 2000/2003 and Exchange 2007/Outlook 2007 environments.
Cause
This is by design of Microsoft Exchange Free/Busy architecture.
Resolution
FIRST
QMM only synchronizes Free/Busy information contained in Schedule + F/B system public folders. Since it is possible to install Exchange 2007 server without public folder store, the target environment needs to have a public folder database created and mounted in order for QMM Free/Busy synchronization to work.
SECOND
If Outlook 2007 is utilized in target Exchange 2007 environment the new Availability service running on CAS (Client Access Server) is going to look into both: new Exchange 2007 Free/Busy stored inside the mailbox itself and legacy Free/Busy stored under Schedule + F/B public folder.
"What does Exchange 2007 Availability Service do?"
http://msexchangeteam.com/archive/2006/10/23/429296.aspx
“The Availability Service is a web service that is deployed on the Client Access Server role. Outlook 2007 clients discover the Availability service via the Auto discover service. The Availability Service is used by Outlook 2007 and Outlook Web Access Scheduling Assistant to:
- Retrieve live Free/Busy information for E2K7 mailboxes
- Retrieve live Free/Busy from other E2K7 forests
- Retrieve published Free/Busy from Public Folders (for legacy mailboxes or for mailboxes using legacy Outlook clients)
- View attendee working hours
- Show meeting time suggestions
As mentioned above, in order for the Availability Service to provide a seamless end user experience, it must be able to interact with legacy systems. To that end, the Availability Service can retrieve data from free/busy public folder stores.
If Outlook 2007 users are not able to see Free/Busy information please follow this troubleshooting path:
a) Is CAS server deployed in the environment?
b) Is Autodiscovery service configured properly with the correct Availability URL?
1. In Outlook 2007 hold Cntrl + Right click on Outlook icon in the notification area.
2. Select "Test E-mail Auto-Configuration"
3. Put in password and uncheck "Use Guessmart" "Secure Guessmart Authentication"
4. Click Test
5. Look at the results and check the Availability, OOF and OAB URLs. If these are not set to the Public URL of Exchange 2007 CAS server then Outlook is unable to communicate with Availability service.
6. On Exchange 2007 CAS server open the Exchange Command Shell.
7. Type Get--WebServicesVirtualDirectory | fl, this should verify the same results that were displayed in Outlook.
8. Type Get--WebServicesVirtualDirectory | set-WebServicesVirtualDirectory -internalurl <your URL here>
9. Type Get--WebServicesVirtualDirectory | set-WebServicesVirtualDirectory -externalurl <your URL here>
10. Type Get--WebServicesVirtualDirectory | fl, this should verify the new changes you just made.
11. Wait a few minutes for this to show up in Outlook 2007.
**Before making such changes it is strongly recommended that Quest Professional Services or Microsoft be consulted. These changes, if misconfigured could damage the Exchange 2007 Organization, and affect migrated and non-migrated users**
NOTE: If F/B messages correspond to the mail-enabled recipients with no mailboxes, that for example were synchronized to represent GAL recipients from another Exchange organization, the following PowerShell commandlet needs to be executed on Exchange 2007:
Add-AvailabilityAddressSpace -ForestName:<namespace> -AccessMethod:PublicFolder
Where <namespace> is the namespace of the mail-enabled objects - for example, quest.com.
THIRD
If Outlook 2007 is running in pure Exchange 2000/2003 environment it will not be able to obtain Free/Busy information from Schedule + F/B folder. To force Outlook 2007 to look for Public Folder based Free/Busy information the registry needs to be modified:
HKEY_CURRENT_USERSoftwareMicrosoftOffice12.0OutlookOptionsCalendar
Value Type: DWORD
Value Name: UseLegacyFB
Values:0 or not set (default behavior which is to use the Availability Service) or 1 (use Public Folder based Free/Busy information)
**Disclaimer: Quest does not provide support for problems that arise from improper modification of the registry. The Windows registry contains information critical to your computer and applications. Make sure you back up the registry before modifying it. For more information on the Windows Registry Editor and how to back up and restore it, refer to Microsoft Article ID 256986 “Description of the Microsoft Windows registry”: http://support.microsoft.com/default.aspx?kbid=256986 .**
The following Microsoft Technet article is helpful when dealing with this topic: http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx
Additional Information
Quest Support is not responsible for configuring or troubleshooting the Exchange 2007 Availability Service. The Quest Migration Manager tool is designed to place free/busy messages within the Exchange schedule + free/busy folder. Configuration of the Outlook clients to read this information falls outside of supports role in a migration, and deals with Exchange 2007 configuration. These configuration changes should be performed very carefully, and if questions arise, Quest Professional Services or Microsoft should be involved.









