Products Solutions Support Services Partners Communities Company

Solution SOL24021

Title

"Class not registered" error when connecting or opening a new Editor Window in v9.0

Problem Description

"Class not registered" error occurs when attempting to connect to a database or by opening a new Editor Window after upgrading to Toad for Oracle v9.0.

Cause

The QExplain2Full.msi installer may not have been executed during installation or there may have been files corrupted when installing on top of a previous installation.

Resolution

RESOLUTION 1:

1. With Toad for Oracle v9.0 closed, locate the QExplain2Full.msi installer in the Toad install directory.
2. Run the QExplain2Full.msi.
3. If there are issues during the run of the QExplain2Full.msi file, try executing it via command line such as the following:

msiexec /i "C:\Program Files\Quest Software\Toad for Oracle\QExplain2Full.msi"

RESOLUTION 2:

Install Toad for Oracle v9.0 into a brand new directory.

RESOLUTION 3:

Install Toad for Oracle v9.1 into a brand new directory.

 

Environment

Product: Toad for Oracle - 9.0.0
Attachments:
Client OS: Windows - All
Server OS: All - All OS Rev
Database: Oracle - All

Feedback

How Useful was this Content?
Not at all useful    1   2   3   4   5    Extremely useful

Do you have a comment concerning this document?

 

Announcements

Featured Support Offering:
Business Critical Support Available NOW - 24x7, 365 days a year